Bug 499373 - blkiomon prints "unaligned access" messages
blkiomon prints "unaligned access" messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: blktrace (Show other bugs)
5.3
ia64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 08:38 EDT by Milos Malik
Modified: 2010-02-03 08:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:41:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2009-05-06 08:38:47 EDT
Description of problem:
I don't know what's the cause of these messages, but they appear on ia64 machines only.

Version-Release number of selected component (if applicable):
blktrace-1.0.0-4.el5 and older releases

How reproducible:
always

Steps to Reproduce:
# mount -t debugfs debugfs /sys/kernel/debug/
# blktrace -w 30 -o - /dev/sda | blkiomon -I 10
blkiomon(22547): unaligned access to 0x600000000000c504, ip=0x4000000000003620
blkiomon(22547): unaligned access to 0x600000000000c544, ip=0x4000000000003660
blkiomon(22547): unaligned access to 0x600000000000c57c, ip=0x4000000000003690
blkiomon(22547): unaligned access to 0x600000000000c5ac, ip=0x40000000000036a0
blkiomon(22547): unaligned access to 0x600000000000c52c, ip=0x40000000000036a1
blkiomon(22547): unaligned access to 0x600000000000c504, ip=0x4000000000003620
blkiomon(22547): unaligned access to 0x600000000000c544, ip=0x4000000000003660
blkiomon(22547): unaligned access to 0x600000000000c57c, ip=0x4000000000003690
blkiomon(22547): unaligned access to 0x600000000000c5ac, ip=0x40000000000036a0
blkiomon(22547): unaligned access to 0x600000000000c52c, ip=0x40000000000036a1
blkiomon(22547): unaligned access to 0x600000000000c5e4, ip=0x4000000000003d50
blkiomon(22547): unaligned access to 0x600000000000c5cc, ip=0x4000000000003d51
blkiomon(22547): unaligned access to 0x600000000000c5dc, ip=0x4000000000003d70
blkiomon(22547): unaligned access to 0x600000000000c5dc, ip=0x4000000000003d90
blkiomon(22547): unaligned access to 0x600000000000c5d4, ip=0x4000000000003d91
# echo $?
0
# umount /sys/kernel/debug/
  
Actual results:
a lot of "unaligned access" messages

Expected results:
no "unaligned access" messages
Comment 1 Eric Sandeen 2009-05-06 16:42:38 EDT
This is due to the packed struct on :

struct blkiomon_stat {
        __u64 time;
        __u32 size_hist[BLKIOMON_SIZE_BUCKETS];
        __u32 d2c_hist[BLKIOMON_D2C_BUCKETS];
        struct minmax size_r;
        struct minmax size_w;
        struct minmax d2c_r;
        struct minmax d2c_w;
        struct minmax thrput_r;
        struct minmax thrput_w;
        __u64 bidir;
        __u32 device;
} __attribute__ ((packed));
Comment 2 Eric Sandeen 2009-05-06 17:55:39 EDT
Potential fix sent upstream

http://marc.info/?l=linux-btrace&m=124164659417701&w=2
Comment 5 Eric Sandeen 2009-05-13 18:54:09 EDT
Committed & built in blktrace-1.0.0-6.el5
Comment 11 errata-xmlrpc 2009-09-02 05:41:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1284.html

Note You need to log in before you can comment on or make changes to this bug.