Bug 499380 - 4.2. RHN Proxy Server Installation Process suggests to do configure-proxy.sh -> command not found
4.2. RHN Proxy Server Installation Process suggests to do configure-proxy.sh ...
Status: CLOSED DUPLICATE of bug 498301
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: John Ha
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 09:18 EDT by Jan Pazdziora
Modified: 2014-08-04 18:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 11:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-05-06 09:18:46 EDT
Description of problem:

On https://FQDN/rhn/help/proxy/rhn530/en-US/s1-installation-install-config.jsp, the documentation says:

4.2. RHN Proxy Server Installation Process

The following instructions describe the RHN Proxy Server installation process:

   1.

      Register the newly-installed Red Hat Enterprise Linux system with Red Hat Network (either the central RHN Servers or your RHN Satellite Server) using the organizational account containing the RHN Proxy Server entitlement with the command: rhn_register.
   2.

      To perform an installation, type the following command:

      configure-proxy.sh

The trouble is, that configure-proxy.sh program is most likely not installed, leading to

# configure-proxy.sh
-bash: configure-proxy.sh: command not found

When I go to https://FQDN/rhn/help/proxy/rhn530/en-US/ch-requirements.jsp, I can see

#

An available RHN Proxy Server entitlement within your RHN Satellite Server account.
#

An available Provisioning entitlement within your RHN Satellite Server account (which should come packaged with your RHN Proxy Server entitlement).
#

Access to the Red Hat Network Tools channel for the installed version of Red Hat Enterprise Linux. This channel includes the configure-proxy.sh installation program necessary to install RHN Proxy Server.
#

All rhncfg* packages installed on the Proxy (from the RHN Tools channel). 

The trouble is that the statement "This channel includes the configure-proxy.sh installation program necessary to install RHN Proxy Server." is false -- the channel contains packages, and there is no information about spacewalk-proxy-installer which needs to be installed. The rhncfg* packages are not enough to get configure-proxy.sh.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090501.1 on i386

How reproducible:

Seen once.

Steps to Reproduce:
1. Try to figure out how to install RHN Proxy 5.3.
2. Use the RHN Proxy documentation to find out how to get that configure-proxy.sh program.
  
Actual results:

The above -- the information is neither in 2.1. Software Requirements, nor in 4.2. RHN Proxy Server Installation Process sections.

Expected results:

It probably should be in both.

Additional info:
Comment 1 Brandon Perkins 2009-05-07 11:53:54 EDT

*** This bug has been marked as a duplicate of bug 498301 ***

Note You need to log in before you can comment on or make changes to this bug.