Bug 499387 - Not using presto (or wrong download size)
Not using presto (or wrong download size)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 522912 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 09:47 EDT by Michael Monreal
Modified: 2010-03-22 12:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 12:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot PK (6.82 KB, image/png)
2009-05-06 09:47 EDT, Michael Monreal
no flags Details
Screenshot yum (7.71 KB, image/png)
2009-05-06 09:48 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-05-06 09:47:23 EDT
I have yum-presto installed. For the same list of updates, PK-updater tells me the size is 77MB. On console, yum says it's just 39MB. I guess either PK is not using presto (iirc it should at this point?) or PK just displays the total package size instead of the download - which would be more useful.
Comment 1 Michael Monreal 2009-05-06 09:47:48 EDT
Created attachment 342646 [details]
Screenshot PK
Comment 2 Michael Monreal 2009-05-06 09:48:23 EDT
Created attachment 342647 [details]
Screenshot yum
Comment 3 Bug Zapper 2009-06-09 11:14:54 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Steven M. Parrish 2009-07-21 21:07:28 EDT
Any updates/comments Richard?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Richard Hughes 2009-07-22 04:20:56 EDT
Without reading the presto source code in any great detail, I would say it's because the yum-presto code is a plugin, and hence when we ask yum the size of the update, it gives us the data without looking at the plugin data. We would have to get a presto developer to help us fix this one properly.
Comment 6 Steven M. Parrish 2009-09-12 19:03:54 EDT
Richard, what do you want to do with this one.  Keep it open as a RFE or close as WONTFIX?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Richard Hughes 2009-09-13 04:33:34 EDT
*** Bug 522912 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Dieter 2009-09-17 01:06:48 EDT
I am happy to help with this on the yum-presto side of things, but I'm not sure how to give you what you need.
Comment 9 Richard Hughes 2009-09-17 03:34:24 EDT
(In reply to comment #8)
> I am happy to help with this on the yum-presto side of things, but I'm not sure
> how to give you what you need.  

From a given pkg, I need to know how to find the total download size of the package. At the moment I'm just using pkg.size, but for presto packages this is obviously the size of the whole rpm, not the size of the delta-rpm that needs to be downloaded. Ideas welcome. Thanks.
Comment 10 Jonathan Dieter 2009-09-17 09:09:25 EDT
Ok, a couple of things I've noticed as I've looked a bit more closely at this.  Yum-presto does most of its work in the predownload_hook, including downloading the presto metadata, so it can't tell you anything before that (and it doesn't change yum's summary).

So I'm not sure why PK and yum have different totals, but I don't think it has anything to do with presto.  It may be that yum checks for already downloaded packages and removes them from the total.  I'm not sure if PackageKit does that.

Note You need to log in before you can comment on or make changes to this bug.