Bug 499423 - mounting partitions in dolphin requires root password
mounting partitions in dolphin requires root password
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 11:59 EDT by Rex Dieter
Modified: 2009-05-11 12:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 12:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-05-06 11:59:58 EDT
Since installing F-11, trying to mount local ntfs partions asks for root password (via kdesu).  Prior to upgrading, this was working for me in F-10 without authorization.

Not sure what's going on yet, but thought I'd get this in bz for tracking purposes for now.
Comment 1 Kevin Kofler 2009-05-06 18:04:54 EDT
I think this is intentional, non-removable partitions need root to mount by default.

This can be tweaked in polkit-kde-authorization (or polkit-gnome-authorization) under org.freedesktop.hal.storage.mount-fixed (Mount file systems from internal drivers). It's already set to require admin authentication here on F9.

I think the previous behavior was a bug, the FUSE mounts weren't recognized as internal.
Comment 2 Kevin Kofler 2009-05-06 18:05:54 EDT
Note: the best way to automount fixed partitions is still to use /etc/fstab.
Comment 3 Rex Dieter 2009-05-11 12:12:16 EDT
A partial workaround is to configure kdesu to use sudo (provided you have sudo access setup):

kwriteconfig \
  --file kdesurc \
  --group super-user-command \
  --key super-user-command sudo

( see also: http://dev-loki.blogspot.com/2006/11/kdesu-with-sudo.html )

Come to think of it, this is perhaps how I did have my previous install setup, and I just forgot about it.
Comment 4 Rex Dieter 2009-05-11 12:30:12 EDT
I'd concur with comment #1 , closing->notabug
Comment 5 Rex Dieter 2009-05-11 12:44:56 EDT
and, I confirmed that the default PolicyKit behavior is to require root pass (with similar behavior under gnome).

Note You need to log in before you can comment on or make changes to this bug.