Bug 499427 - [2.6.29] BUG: unable to handle kernel NULL pointer dereference at 00000004
[2.6.29] BUG: unable to handle kernel NULL pointer dereference at 00000004
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 12:05 EDT by Orion Poplawski
Modified: 2009-09-04 22:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 22:56:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-05-06 12:05:41 EDT
Description of problem:

Since running 2.6.29.2-52.fc10, seen this each morning.  Running 2.6.29.1-42.fc10 previously.

May  5 05:35:25 saga kernel: BUG: unable to handle kernel NULL pointer dereference at 00000004
May  5 05:35:25 saga kernel: IP: [<c0505731>] inode_has_perm+0x21/0x62
May  5 05:35:25 saga kernel: *pde = f7b68067                          
May  5 05:35:25 saga kernel: Oops: 0000 [#1] SMP                      
May  5 05:35:25 saga kernel: last sysfs file: /sys/devices/platform/w83627hf.656/temp3_input
May  5 05:35:25 saga kernel: Modules linked in: nfs nfsd lockd nfs_acl auth_rpcgss exportfs bridge stp bnep sco l2cap bluetooth autofs4 w83627hf w83781d hwmon_vid ds1621 adm1021 hwmon sunrpc ipv6 p4_clockmod dm_multipath uinput pcspkr i2c_i801 i2c_core iTCO_wdt iTCO_vendor_support intel_rng e100 mii e1000 e7xxx_edac edac_core sym53c8xx scsi_transport_spi sata_promise sata_mv ata_generic pata_acpi raid456 async_xor async_memcpy async_tx xor raid1 [last unloaded: scsi_wait_scan]
May  5 05:35:25 saga kernel:
May  5 05:35:25 saga kernel: Pid: 3808, comm: nfsd Not tainted (2.6.29.2-52.fc10.i686 #1) X5DPL
May  5 05:35:25 saga kernel: EIP: 0060:[<c0505731>] EFLAGS: 00010246 CPU: 3
May  5 05:35:25 saga kernel: EIP is at inode_has_perm+0x21/0x62
May  5 05:35:25 saga kernel: EAX: 00000000 EBX: 00000000 ECX: 00000004 EDX: eb666478
May  5 05:35:25 saga kernel: ESI: f5235400 EDI: f6639e00 EBP: f55d0e88 ESP: f55d0e3c
May  5 05:35:25 saga kernel: DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
May  5 05:35:25 saga kernel: Process nfsd (pid: 3808, ti=f55d0000 task=f4a39940 task.ti=f55d0000)
May  5 05:35:25 saga kernel: Stack:
May  5 05:35:25 saga kernel: 00000004 4ea137c7 0000446d 11270000 ebace804 f55d0e9c f82c686a f66394ec
May  5 05:35:25 saga kernel: f55d0e70 c048225e f4a39bac f6639e6c f66394ec f55d0e7c c0507e59 f6639e64
May  5 05:35:25 saga kernel: 00000004 f5235400 eb666478 f55d0ea4 c0507f41 00000000 f6639e00 f5235400
May  5 05:35:25 saga kernel: Call Trace:
May  5 05:35:25 saga kernel: [<f82c686a>] ? nfsd_setuser_and_check_port+0x55/0x5a [nfsd]
May  5 05:35:25 saga kernel: [<c048225e>] ? kmemdup+0x18/0x33
May  5 05:35:25 saga kernel: [<c0507e59>] ? selinux_cred_prepare+0x13/0x26
May  5 05:35:25 saga kernel: [<c0507f41>] ? selinux_dentry_open+0xd5/0xdd
May  5 05:35:25 saga kernel: [<c05017c2>] ? security_dentry_open+0xf/0x11
May  5 05:35:25 saga kernel: [<c049ab6f>] ? __dentry_open+0xf5/0x207
May  5 05:35:25 saga kernel: [<c049ace4>] ? dentry_open+0x63/0x6e
May  5 05:35:25 saga kernel: [<f82c850a>] ? nfsd_open+0x123/0x149 [nfsd]
May  5 05:35:25 saga kernel: [<f82c877e>] ? nfsd_write+0x67/0xaa [nfsd]
May  5 05:35:25 saga kernel: [<f82ce088>] ? nfsd3_proc_write+0xa7/0xbd [nfsd]
May  5 05:35:25 saga kernel: [<f82c4205>] ? nfsd_dispatch+0xcf/0x1a2 [nfsd]
May  5 05:35:25 saga kernel: [<f814fa04>] ? svc_process+0x379/0x587 [sunrpc]
May  5 05:35:25 saga kernel: [<f82c4731>] ? nfsd+0x117/0x167 [nfsd]
May  5 05:35:25 saga kernel: [<f82c461a>] ? nfsd+0x0/0x167 [nfsd]
May  5 05:35:25 saga kernel: [<c043ee6b>] ? kthread+0x3b/0x61
May  5 05:35:25 saga kernel: [<c043ee30>] ? kthread+0x0/0x61
May  5 05:35:25 saga kernel: [<c040463f>] ? kernel_thread_helper+0x7/0x10
May  5 05:35:25 saga kernel: Code: ff 5b 5e 8d 65 f8 5b 5e 5d c3 55 89 e5 57 89 c7 56 31 c0 53 83 ec 40 8b 5d 08 89 4d b4 f6 82 45 01 00 00 02 75 3e 8b 47 58 85 db <8b> 40 04 89 45 b8 8b b2 4c 01 00 00 75 16 b9 0e 00 00 00 89 d8
May  5 05:35:25 saga kernel: EIP: [<c0505731>] inode_has_perm+0x21/0x62 SS:ESP 0068:f55d0e3c
May  5 05:35:26 saga kernel: ---[ end trace ad637a5e53407578 ]---


May  6 05:34:29 saga kernel: BUG: unable to handle kernel NULL pointer dereference at
 00000004
May  6 05:34:29 saga kernel: IP: [<c0505731>] inode_has_perm+0x21/0x62
May  6 05:34:29 saga kernel: *pde = f7b68067
May  6 05:34:29 saga kernel: Oops: 0000 [#2] SMP
May  6 05:34:29 saga kernel: last sysfs file: /sys/devices/platform/w83627hf.656/temp
3_input
May  6 05:34:29 saga kernel: Modules linked in: ext4 jbd2 crc16 nfs nfsd lockd nfs_ac
l auth_rpcgss exportfs bridge stp bnep sco l2cap bluetooth autofs4 w83627hf w83781d h
wmon_vid ds1621 adm1021 hwmon sunrpc ipv6 p4_clockmod dm_multipath uinput pcspkr i2c_
i801 i2c_core iTCO_wdt iTCO_vendor_support intel_rng e100 mii e1000 e7xxx_edac edac_c
ore sym53c8xx scsi_transport_spi sata_promise sata_mv ata_generic pata_acpi raid456 a
sync_xor async_memcpy async_tx xor raid1 [last unloaded: scsi_wait_scan]
May  6 05:34:29 saga kernel:
May  6 05:34:29 saga kernel: Pid: 3820, comm: nfsd Tainted: G      D    (2.6.29.2-52.
fc10.i686 #1) X5DPL
May  6 05:34:29 saga kernel: EIP: 0060:[<c0505731>] EFLAGS: 00010246 CPU: 1
May  6 05:34:29 saga kernel: EIP is at inode_has_perm+0x21/0x62
May  6 05:34:29 saga kernel: EAX: 00000000 EBX: 00000000 ECX: 00000004 EDX: cc4c4288
May  6 05:34:29 saga kernel: ESI: f529f100 EDI: f4bd9380 EBP: f4a87e88 ESP: f4a87e3c
May  6 05:34:29 saga kernel: DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
May  6 05:34:29 saga kernel: Process nfsd (pid: 3820, ti=f4a87000 task=f4883280 task.
ti=f4a87000)
May  6 05:34:29 saga kernel: Stack:
May  6 05:34:29 saga kernel: 00000004 a3abaa74 000092f4 11270000 f5705804 f4a87e9c f4
a87000 c05322ac
May  6 05:34:29 saga kernel: 0a634000 00000000 f48834ec c0403e2b ec05f440 f4849900 f4
814840 00000000
May  6 05:34:29 saga kernel: 00000004 f529f100 cc4c4288 f4a87ea4 c0507f41 00000000 f4
bd9380 f529f100
May  6 05:34:29 saga kernel: Call Trace:
May  6 05:34:29 saga kernel: [<c05322ac>] ? trace_hardirqs_on_thunk+0xc/0x10
May  6 05:34:29 saga kernel: [<c0403e2b>] ? restore_nocheck_notrace+0x0/0xe
May  6 05:34:29 saga kernel: [<c0507f41>] ? selinux_dentry_open+0xd5/0xdd
May  6 05:34:29 saga kernel: [<c05017c2>] ? security_dentry_open+0xf/0x11
May  6 05:34:29 saga kernel: [<c049ab6f>] ? __dentry_open+0xf5/0x207
May  6 05:34:29 saga kernel: [<c049ace4>] ? dentry_open+0x63/0x6e
May  6 05:34:29 saga kernel: [<f82c850a>] ? nfsd_open+0x123/0x149 [nfsd]
May  6 05:34:29 saga kernel: [<f82c877e>] ? nfsd_write+0x67/0xaa [nfsd]
May  6 05:34:29 saga kernel: [<f82ce088>] ? nfsd3_proc_write+0xa7/0xbd [nfsd]
May  6 05:34:29 saga kernel: [<f82c4205>] ? nfsd_dispatch+0xcf/0x1a2 [nfsd]
May  6 05:34:29 saga kernel: [<f814fa04>] ? svc_process+0x379/0x587 [sunrpc]
May  6 05:34:29 saga kernel: [<f82c4731>] ? nfsd+0x117/0x167 [nfsd]
May  6 05:34:29 saga kernel: [<f82c461a>] ? nfsd+0x0/0x167 [nfsd]
May  6 05:34:29 saga kernel: [<c043ee6b>] ? kthread+0x3b/0x61
May  6 05:34:29 saga kernel: [<c043ee30>] ? kthread+0x0/0x61
May  6 05:34:29 saga kernel: [<c040463f>] ? kernel_thread_helper+0x7/0x10
May  6 05:34:29 saga kernel: Code: ff 5b 5e 8d 65 f8 5b 5e 5d c3 55 89 e5 57 89 c7 56 31 c0 53 83 ec 40 8b 5d 08 89 4d b4 f6 82 45 01 00 00 02 75 3e 8b 47 58 85 db <8b> 40 04 89 45 b8 8b b2 4c 01 00 00 75 16 b9 0e 00 00 00 89 d8
May  6 05:34:29 saga kernel: EIP: [<c0505731>] inode_has_perm+0x21/0x62 SS:ESP 0068:f4a87e3c
May  6 05:34:29 saga kernel: ---[ end trace ad637a5e53407579 ]---
Comment 1 Orion Poplawski 2009-05-08 12:54:47 EDT
Might be a dupe of bug #494067
Comment 2 W. Michael Petullo 2009-05-11 21:06:00 EDT
I received the following similar error when using kernel-2.6.29.1-102.fc11.i586:

UG: unable to handle kernel NULL pointer dereference at 00000004
IP: [<c05332b8>] inode_has_perm+0x25/0x6a
*pde = 0cda2067 *pte = 00000000
Oops: 0000 [#1] SMP
last sysfs file: /sys/devices/pci0000:00/0000:00:11.1/host1/target1:0:0/1:0:0:0/block/sdb/size
Modules linked in: ipt_LOG nfsd lockd nfs_acl auth_rpcgss exportfs autofs4 sunrpc nf_conntrack_netbios_ns ip6t_REJECT ip6table_filter ip6_tables ipv6 snd_via82xx gameport ppdev snd_ac97_codec ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd_mpu401_uart i2c_viapro snd_rawmidi snd_seq_device i2c_core floppy snd pcspkr via_rhine via_ircc soundcore mii irda crc_ccitt usblp firewire_ohci firewire_core crc_itu_t parport_pc parport usb_storage ata_generic pata_acpi pata_via [last unloaded: scsi_wait_scan]

Pid: 1534, comm: nfsd Not tainted (2.6.29.1-102.fc11.i586 #1) VT8623-8235
EIP: 0060:[<c05332b8>] EFLAGS: 00010246 CPU: 0
EIP is at inode_has_perm+0x25/0x6a
EAX: 00000000 EBX: 00000000 ECX: 00000002 EDX: cd4f0858
ESI: 00000002 EDI: ccbc1f00 EBP: cca21e88 ESP: cca21e3c
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process nfsd (pid: 1534, ti=cca20000 task=cca18000 task.ti=cca20000)
Stack:
 00000046 0000000b 0000003b cca21e54 c043419d c08bc300 c08e459c cca21e60
 c08e459c cca21e88 c049a950 cca20000 00000246 00000001 cca21e94 00000246
 ccbc1f00 cd4f0858 ccbc1f00 cca21ea4 c0535522 00000000 cd524b20 ccbc1f00
Call Trace:
 [<c043419d>] ? do_softirq+0x68/0x7e
 [<c049a950>] ? __slab_alloc+0xd7/0x411
 [<c0535522>] ? selinux_dentry_open+0xd5/0xdd
 [<c052e836>] ? security_dentry_open+0x14/0x16
 [<c049f36d>] ? __dentry_open+0xf7/0x205
 [<c049f4e7>] ? dentry_open+0x6c/0x76
 [<cf86d661>] ? nfsd_open+0x10a/0x135 [nfsd]
 [<cf3acea0>] ? ip_map_lookup+0xd3/0xdb [sunrpc]
 [<cf86d9ed>] ? nfsd_read+0x8a/0xc4 [nfsd]
 [<cf8733b6>] ? nfsd3_proc_read+0xcb/0x112 [nfsd]
 [<cf874b9d>] ? nfs3svc_decode_readargs+0x8e/0xe4 [nfsd]
 [<cf869218>] ? nfsd_dispatch+0xd6/0x1a1 [nfsd]
 [<cf3a9c70>] ? svc_process+0x391/0x596 [sunrpc]
 [<cf869744>] ? nfsd+0x11c/0x16c [nfsd]
 [<cf869628>] ? nfsd+0x0/0x16c [nfsd]
 [<c04405c4>] ? kthread+0x41/0x65
 [<c0440583>] ? kthread+0x0/0x65
 [<c04048f7>] ? kernel_thread_helper+0x7/0x10
Code: e0 ea 5b 5e 5d c3 55 89 e5 57 56 53 83 ec 40 66 66 66 66 90 8b 5d 08 89 c7 31 c0 f6 82 45 01 00 00 02 89 ce 75 42 8b 47 58 85 db <8b> 40 04 89 45 b4 8b 82 4c 01 00 00 89 45 b8 75 16 b9 0e 00 00
EIP: [<c05332b8>] inode_has_perm+0x25/0x6a SS:ESP 0068:cca21e3c---[ end trace 6315134d7fafb844 ]---
Comment 3 Chuck Ebbert 2009-05-18 02:07:46 EDT
(In reply to comment #1)
> Might be a dupe of bug #494067  

Yes it's the same bug hitting F10/i686 instead of F11/x86_64. And it can't happen on 2.6.27 because the credentials code is different there.
Comment 4 Chuck Ebbert 2009-08-17 07:55:42 EDT
This was fixed in 2.6.29.6-91.fc10

Note You need to log in before you can comment on or make changes to this bug.