Bug 499436 - NSS conflict when updating glibc, only
NSS conflict when updating glibc, only
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kai Engert (:kaie)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 12:36 EDT by Kai Engert (:kaie)
Modified: 2013-01-10 00:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 15:37:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2009-05-06 12:36:52 EDT
We recently introduced the new sub-package nss-softokn-freebl.
We got the following bug report on fedora-devel mailing list:

> Transaction Check Error:
>  file /lib64/libfreebl3.so from install of
> nss-softokn-freebl-3.12.2.99.3-7.fc11.x86_64 conflicts with file from
> package nss-3.12.2.0-4.fc11.x86_64
> ...     
> I am still getting this with nss-softokn-freebl-3.12.3-3.fc11.x86_64.

I suspect the user attempted to update glibc.rpm, without requesting an update of nss.rpm

This pulled in the new nss-softokn-freebl.rpm, but yum/rpm didn't know about this conflict.

Since we can't require nss-softokn-freebl.rpm to pull in nss.rpm, I propose to add the following in the spec, to the
  %package softokn-freebl
section:
  Conflicts:        nss < 3.12.2.99.3-5

Package 3.12.2.99.3-5 was the first to include the new subpackage.
Comment 1 Kai Engert (:kaie) 2009-05-06 12:41:27 EDT
Can you please confirm my theory is correct?

Nevertheless, I believe this chance is necessary, I'll commit it to rawhide.
Comment 2 Kai Engert (:kaie) 2009-05-06 12:48:26 EDT
I guess it's unlikely someone will attempt an update from F-10 to F-11 for glibc, only. Nevertheless, do you want me to build this fix into F-11 branch now?
Comment 3 Kai Engert (:kaie) 2009-05-06 13:09:39 EDT
debarshi.ray, nss-3.12.3-4 will soon appear in rawhide, does it fix your problem?

I realize in order to propose this for Fedora 11 prior to the release I'll have to follow https://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy

I'll do so after getting testing feedback
Comment 4 Debarshi Ray 2009-05-06 15:57:41 EDT
(In reply to comment #0)

> I suspect the user attempted to update glibc.rpm, without requesting an update
> of nss.rpm

I was trying to do:
# yum install gcc-c++

Finally, I decided to forcibly remove nss (# rpm --nodeps -e nss), which was a stupid thing to do, since rpm stopped working after that and I essentially lost the Rawhide VM.

So what I can do is try to install from the Fedora 11 Preview LiveCD and see if I can install gcc-c++ now. Before, I was using the Fedora 11 Beta LiveCD.
Comment 5 Kai Engert (:kaie) 2009-05-07 15:37:13 EDT
I suspect your attempt to install g++ pulled in a newer version of glibc, which pulled in the new softokn package.

As you reported this bug against rawhide, I'm closing it.

Right now I can't imagine a scenario where this would break an update from F-10 to F-11, as the nss package will certainly get updated, too. So I'm not sure this bug should ask for an exception to the final development freeze for F-11.
Comment 6 Debarshi Ray 2009-05-08 00:12:39 EDT
(In reply to comment #5)
> I suspect your attempt to install g++ pulled in a newer version of glibc, which
> pulled in the new softokn package.

I had installed Fedora 11 Beta x86_64 from the LiveCD and tried to install gcc-c++ over it. This triggered the problem. The inability to install gcc-c++ was a show-stopper for me, and if it now works, then great!

Thanks for filing the bug and following it up.
Comment 7 Kai Engert (:kaie) 2009-05-08 13:08:28 EDT
(In reply to comment #6)
> 
> I had installed Fedora 11 Beta x86_64 from the LiveCD and tried to install
> gcc-c++ over it. This triggered the problem. The inability to install gcc-c++
> was a show-stopper for me, and if it now works, then great!


I have not tested this scenario. The bug should now be fixed for future rawhide, but the fix is not yet in F-11, so your F-11 scenario might still fail.

Note You need to log in before you can comment on or make changes to this bug.