Bug 499461 - Create a (take) link next to the Assigned To field to allow quick reassign to self
Create a (take) link next to the Assigned To field to allow quick reassign to...
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 14:35 EDT by David Lawrence
Modified: 2009-07-20 11:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 11:01:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add take shortcut to reassign bug yourself (v1) (1.35 KB, patch)
2009-07-16 13:37 EDT, David Lawrence
nelhawar: review+
Details | Diff

  None (edit)
Description David Lawrence 2009-05-06 14:35:10 EDT
Description of problem:
Currently the Assigned To field looks like:

Assigned To: David Lawrence (dkl@redhat.com) (edit) 

I propose adding another link (take) to the right off (edit) that will display only if the assigned to is not currently yourself. 

Assigned To: David Lawrence (dkl@redhat.com) (edit) (take)

When you click on (take), it will use javascript to unhide the assigned to edit text field, and replace the current owner with your login name. Then you can 
just click on Commit to save the change. This keeps the user from having to first click on (edit) and then manually enter their login name.

Dave
Comment 1 David Lawrence 2009-07-16 13:37:03 EDT
Created attachment 354022 [details]
Patch to add take shortcut to reassign bug yourself (v1)

Simple patch that adds a (take) shortcut that will change the assignee to the person viewing the bug report. It does not commit the change though in case the user wants to make other changes.

Please review, low priority
Dave
Comment 2 Noura El hawary 2009-07-20 06:35:29 EDT
Comment on attachment 354022 [details]
Patch to add take shortcut to reassign bug yourself (v1)

Patch Looks good Dave, tested it on bz-web2 and works perfect I really like the idea too :).

Thanks,
Noura
Comment 3 David Lawrence 2009-07-20 11:01:18 EDT
Thanks Noura. Committed.

Note You need to log in before you can comment on or make changes to this bug.