Bug 499512 - Solaris packages upgraded via Satellite are not updated with Satellite after running rhn_check
Solaris packages upgraded via Satellite are not updated with Satellite after ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Steve Salevan
:
Depends On:
Blocks: 457000
  Show dependency treegraph
 
Reported: 2009-05-06 18:07 EDT by Steve Salevan
Modified: 2009-09-10 15:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:41:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-05-06 18:07:10 EDT
Description of problem:
If a user selects an upgradeable package on a Solaris machine to be upgraded via the SDC or the SSM and runs rhn_check, despite the package being successfully installed (as verified by pkginfo), the SDC will not be updated to report that the package was installed.

As a result, the package is still listed as available for installation under "Upgradeable Packages" in the SDC.

Version-Release number of selected component (if applicable):
530, 5/1 build
rhn-solaris-bootstrap-5.3.0-8-sparc-sol10

How reproducible:
Always (to the best of my knowledge)

Steps to Reproduce:
1. Register a Solaris machine to a Satellite
2. Assign it to a channel that contains packages that can upgrade packages currently on the Solaris machine 
3. Schedule this package for upgrade via the SDC or SSM
4. Run rhn_check on the Solaris client
  
Actual results:
Package installed (and you can verify installation with a pkginfo -l), package installation event marked as completed and successful in system's events page, but SDC not updated

Expected results:
SDC updated after upgrade process

Additional info:
Comment 1 Clifford Perry 2009-05-07 11:38:00 EDT
This looks like a dupe of the issue that Shannon (et all) was investigating where the UI was out of sync with the client. 

Shannon, if you agree, feel free to close out as dupe or move to MODIFIED and then ON_QA once we have an ISO drop with code in it.

Cliff
Comment 2 Clifford Perry 2009-05-07 11:38:21 EDT
<shughes> bug 496655
<shughes> bug 498273
Comment 3 Shannon Hughes 2009-05-08 16:38:19 EDT
i agree, but to be on the safe side, lets move to modified and to on qa for next iso.
Comment 4 Shannon Hughes 2009-05-20 12:02:46 EDT
mass move to onqa
Comment 5 Steve Salevan 2009-07-02 16:44:41 EDT
VERIFIED on 6/25 build.
Comment 6 Brandon Perkins 2009-09-10 15:41:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.