Bug 499525 - Erlang has Missing Dependency: libc.so.6(GLIBC_PRIVATE)
Erlang has Missing Dependency: libc.so.6(GLIBC_PRIVATE)
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: erlang (Show other bugs)
el5
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-06 22:34 EDT by Allisson Azevedo
Modified: 2009-06-20 01:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-20 01:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allisson Azevedo 2009-05-06 22:34:10 EDT
Today i try to build couchdb 0.9.0 and failed, the log:

DEBUG backend.py:554:  /usr/bin/yum --installroot /var/lib/mock/fedora-5-i386-epel-5d04acdeb8514436647fb093f23544003cb73cbf/root/  install  'erlang' 'libicu-devel' 'js-devel' 'curl-devel' 'help2man'
DEBUG util.py:280:  Executing command: /usr/bin/yum --installroot /var/lib/mock/fedora-5-i386-epel-5d04acdeb8514436647fb093f23544003cb73cbf/root/  install  'erlang' 'libicu-devel' 'js-devel' 'curl-devel' 'help2man'
DEBUG util.py:256:  erlang-R12B-5.6.el5.i386 from testing has depsolving problems
DEBUG util.py:256:    --> Missing Dependency: libc.so.6(GLIBC_PRIVATE) is needed by package erlang-R12B-5.6.el5.i386 (testing)
DEBUG util.py:256:  Error: Missing Dependency: libc.so.6(GLIBC_PRIVATE) is needed by package erlang-R12B-5.6.el5.i386 (testing)
DEBUG util.py:256:   You could try using --skip-broken to work around the problem
DEBUG util.py:256:   You could try running: package-cleanup --problems
DEBUG util.py:256:                          package-cleanup --dupes
DEBUG util.py:256:                          rpm -Va --nofiles --nodigest
DEBUG util.py:256:  The program package-cleanup is found in the yum-utils package.
DEBUG util.py:319:  Child returncode was: 1

http://buildsys.fedoraproject.org/logs/fedora-5-epel/2201-couchdb-0.9.0-1.el5/i386/root.log
Comment 1 Peter Lemenkov 2009-05-07 04:52:26 EDT
Confirmed.
Comment 2 Peter Lemenkov 2009-05-07 06:48:40 EDT
Seems, that this is a resurrected (accidentally) bug 458646:

https://bugzilla.redhat.com/show_bug.cgi?id=458646

I think, it affects only ix86 targets. Anywat, I just added necessary commandline switch back and started rebuilding the package.
Comment 3 Peter Lemenkov 2009-05-07 06:49:38 EDT
Koji scratchbuild for EL-5:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1340400
Comment 4 Allisson Azevedo 2009-05-07 07:11:48 EDT
I try again and get error for ppc too:

DEBUG backend.py:554:  /usr/bin/yum --installroot /var/lib/mock/fedora-5-ppc-epel-8fca81c1f6fd4878ae3b5cb345f00ac9fe824675/root/  install  'erlang' 'libicu-devel' 'js-devel' 'curl-devel' 'help2man'
DEBUG util.py:280:  Executing command: /usr/bin/yum --installroot /var/lib/mock/fedora-5-ppc-epel-8fca81c1f6fd4878ae3b5cb345f00ac9fe824675/root/  install  'erlang' 'libicu-devel' 'js-devel' 'curl-devel' 'help2man'
DEBUG util.py:256:  erlang-R12B-5.6.el5.ppc from testing has depsolving problems
DEBUG util.py:256:    --> Missing Dependency: libc.so.6(GLIBC_PRIVATE) is needed by package erlang-R12B-5.6.el5.ppc (testing)
DEBUG util.py:256:  Error: Missing Dependency: libc.so.6(GLIBC_PRIVATE) is needed by package erlang-R12B-5.6.el5.ppc (testing)
DEBUG util.py:256:   You could try using --skip-broken to work around the problem
DEBUG util.py:256:   You could try running: package-cleanup --problems
DEBUG util.py:256:                          package-cleanup --dupes
DEBUG util.py:256:                          rpm -Va --nofiles --nodigest
DEBUG util.py:256:  The program package-cleanup is found in the yum-utils package.
DEBUG util.py:319:  Child returncode was: 1

http://buildsys.fedoraproject.org/logs/fedora-5-epel/2223-couchdb-0.9.0-1.el5/ppc/root.log

But, my scratch build for EL-5 builds fine:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1340493
Comment 6 Peter Lemenkov 2009-05-07 23:48:01 EDT
Good. Let's wait while erlang-R12B-5.6.el5.1 hits epel-updates.
Comment 7 Peter Lemenkov 2009-06-20 01:41:33 EDT
erlang-R12B-5.6.el5.1 available in epel.

Note You need to log in before you can comment on or make changes to this bug.