Bug 499562 - Kernel option help screens in grub not correct
Kernel option help screens in grub not correct
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 04:21 EDT by Andrew Cannon
Modified: 2009-05-11 15:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 15:29:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified general.msg file with proposed changes. (1.01 KB, patch)
2009-05-07 04:37 EDT, Andrew Cannon
no flags Details | Diff
Modified options.msg file (975 bytes, patch)
2009-05-07 04:38 EDT, Andrew Cannon
no flags Details | Diff
Modified param.msg file (573 bytes, patch)
2009-05-07 04:39 EDT, Andrew Cannon
no flags Details | Diff
Modified rescue.msg file (550 bytes, patch)
2009-05-07 04:39 EDT, Andrew Cannon
no flags Details | Diff

  None (edit)
Description Andrew Cannon 2009-05-07 04:21:06 EDT
Description of problem:
When trying to install F11-Preview, I was trying to follow the advice in the boot menu options; i.e. those in boot.iso/isolinux/params.msg, however, the new GRUB doesn't seem to accept that format.  This needs reworking for the full F11 release.

Version-Release number of selected component (if applicable):
Fedora 11-Preview

How reproducible:
Always

Steps to Reproduce:
1. Boot from CD/DVD 
2. Pass options such as linux askmethod
3. 
  
Actual results:
Get returned to the GRUB options screen

Expected results:
Boot using the alternative methods listed in the askmethod script.

Additional info:
Currently on F11-Preview cd for x86-64, and maybe others.
Comment 1 Andrew Cannon 2009-05-07 04:22:21 EDT
Sorry, not a booty bug, more like a GRUB bug.
Comment 2 Andrew Cannon 2009-05-07 04:37:27 EDT
Created attachment 342799 [details]
modified general.msg file with proposed changes.

I've modified general.msg, options.msg, params.msg and rescue.msg to reflect what I believe is the correct wording.  If not, please ignore these attachments or suggest new wording.
Comment 3 Andrew Cannon 2009-05-07 04:38:28 EDT
Created attachment 342801 [details]
Modified options.msg file
Comment 4 Andrew Cannon 2009-05-07 04:39:07 EDT
Created attachment 342802 [details]
Modified param.msg file
Comment 5 Andrew Cannon 2009-05-07 04:39:39 EDT
Created attachment 342803 [details]
Modified rescue.msg file
Comment 6 Jeremy Katz 2009-05-11 15:29:15 EDT
Thanks for the feedback.  There's a fair bit more out-dated with these messages.  And since we no longer show the messages except in very very special cases, we've instead gone the route of removing the messages so that we don't have to worry as much about them.

Note You need to log in before you can comment on or make changes to this bug.