Bug 49958 - Missing BuildPreReq: popt in initscripts-5.83 RPM
Missing BuildPreReq: popt in initscripts-5.83 RPM
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-25 13:21 EDT by Bhavana Nagendra
Modified: 2014-03-16 22:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 13:43:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bhavana Nagendra 2001-07-25 13:21:05 EDT
Description of Problem:
initscripts/src/usleep.c includes file "popt.h"
This file ofcourse doesn't exist in the current directory.
This results in a slew of errors.  This can be avoided if the 
spec file mentions the BuildPrereq: popt RPM and libpopt.a is
installed.

 $ rpm -qf /usr/lib/libpopt.a
popt-1.6.2-8
Comment 1 Bill Nottingham 2001-07-25 13:49:41 EDT
Fixed in CVS, will be in 6.08-1.

Note You need to log in before you can comment on or make changes to this bug.