Bug 499580 - F11Preview: anaconda writes ifcfg-eth0 with unquoted NAME parameter
F11Preview: anaconda writes ifcfg-eth0 with unquoted NAME parameter
Status: CLOSED DUPLICATE of bug 497485
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 06:04 EDT by Jan ONDREJ
Modified: 2009-05-07 10:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 10:01:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2009-05-07 06:04:27 EDT
Description of problem:
After an installation of F11-Preview in qemu, this is content of ifcfg-eth0:
[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth0
BOOTPROTO=dhcp
DHCPCLASS=
HWADDR=54:52:00:2c:7a:36
MTU=1500
NAME=System eth0
ONBOOT=yes
PEERDNS=yes
PEERROUTES=yes
TYPE=Ethernet
UUID=5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03
MTU=1500
[root@localhost ~]# 

Take a look at "NAME=" parameter, where string is not inside "".
By running this from network start script, this displays:
eth0: command not found

Version-Release number of selected component (if applicable):
Fedora 11-Preview
initscripts-8.94-1.i586

Steps to Reproduce:
1. try to install F11-Preview in qemu
  
Actual results:
[root@localhost ~]# ifup eth0
./ifcfg-eth0: line 7: eth0: command not found
./ifcfg-eth0: line 7: eth0: command not found


Expected results:
No command not found errors.

Additional info:
I am not sure, if it's a bug of anaconda, initscripts, NetworkManager or something else.
Please change component, if I missed.
Comment 1 Mark McLoughlin 2009-05-07 06:15:33 EDT
More likely a bug in NetworkManager:

  1) Is "System eth0" appropriate for NAME ?

  2) shvar.c should quote strings like this
Comment 2 Chris Lumens 2009-05-07 10:01:00 EDT

*** This bug has been marked as a duplicate of bug 497485 ***

Note You need to log in before you can comment on or make changes to this bug.