Bug 499615 - System error with yum-plugin-rpm-warm-cache
System error with yum-plugin-rpm-warm-cache
Status: CLOSED DUPLICATE of bug 498836
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 08:55 EDT by Nicolas Chauvet (kwizart)
Modified: 2014-01-21 18:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 12:12:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2009-05-07 08:55:00 EDT
Description of problem: Once yum-plugin-rpm-warm-cache is installed on F-11 every yum transaction (install/update/remove) will output this errors few second after it has suceed. 
This seems to be related to some post-transaction plugin, and maybe refresh-packagekit...

--------------
Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2461, in _check_init
    self.yumbase.repos.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 79, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rpm-warm-cache.py", line 32, in postreposetup_hook
    cmd = commands[0]
TypeError: 'NoneType' object is unsubscriptable
--------------


Version-Release number of selected component (if applicable):
yum-utils-1.1.21-2.fc11.noarch

How reproducible:
always

Steps to Reproduce:
1. yum install yum-plugins\*
2. yum install any_random_package
3. once package is installed, an error message is seen about the rpm-warm-cache yum plugin.
  
Actual results:
A system error is seen

Expected results:
should process quitely

Additional info:
Comment 1 James Antill 2009-05-07 12:12:03 EDT

*** This bug has been marked as a duplicate of bug 498836 ***

Note You need to log in before you can comment on or make changes to this bug.