Bug 499631 - packages burlap and hessian requires servletapi4
packages burlap and hessian requires servletapi4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Jan Hutař
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-05-07 09:49 EDT by Jan Hutař
Modified: 2009-09-10 16:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:36:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn-installation.log (6.72 KB, text/plain)
2009-05-07 09:49 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2009-05-07 09:49:02 EDT
Created attachment 342845 [details]
rhn-installation.log

Description of problem:
When I try to install on the RHEL4, I'm getting installation issues.


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL4-re20090505.1


How reproducible:
always


Steps to Reproduce:
1. # /mnt/redhat/devel/candidate-trees/Satellite-5.3.0-RHEL4-re20090505.1/i386/i386//install.pl --answer-file=/mnt/tests/CoreOS/RHN-Satellite/Installer/Sanity/install/answers.txt --non-interactive --disconnected --run-updater


Actual results:
The following packages were added to your selection to satisfy dependencies:

Name                                    Version        Release
--------------------------------------------------------------
perl-IO-Zlib                            1.04           4.2.el4             

No updates available for this system
ERROR: RPM dependency error.  The message was:
Dependencies should have already been resolved, but they are not.
Unresolved rpm dependencies:

Package burlap  3.0.8-1jpp_1rh requires servletapi4
Package hessian  3.0.8-1jpp_1rh requires servletapi4


Expected results:
No dependency issues


Additional info:
Discovered in this RHTS job:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=57723
Comment 1 Jesus M. Rodriguez 2009-05-07 13:26:42 EDT
servletapi4 is REQUIRED on the el4 composes. But NOT on the el5.

I installed servletapi4 by hand then proceeded with the installation and it worked fine.
Comment 2 Jesus M. Rodriguez 2009-05-07 13:32:26 EDT
fixed in 507.1 compose
Comment 3 Jan Hutař 2009-05-21 07:53:24 EDT
VERIFIED on RHEL4 with Satellite-5.3.0-RHEL4-re20090520.0-i386

All required packages have been installed

# rpm -q burlap hessian servletapi4
burlap-3.0.8-1jpp_1rh.noarch
hessian-3.0.8-1jpp_1rh.noarch
servletapi4-4.0.4-3jpp_5rh.noarch
Comment 4 Steve Salevan 2009-08-13 11:37:14 EDT
RELEASE_PENDING from latest Stage build.
Comment 5 Brandon Perkins 2009-09-10 16:36:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.