Bug 499655 - Includes/Provides directory it MUST NOT
Includes/Provides directory it MUST NOT
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openchange (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 11:07 EDT by Michael Schwendt
Modified: 2009-05-19 20:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.8.2-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 07:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-05-07 11:07:51 EDT
$ rpmls -p openchange-devel-0.8.2-1.fc11.x86_64.rpm|grep pkg|grep ^d
drwxr-xr-x  /usr/lib64/pkgconfig

$ rpmls -p openchange-devel-0.8.2-1.fc11.i586.rpm|grep pkg|grep ^d
drwxr-xr-x  /usr/lib/pkgconfig

Your package must not include this directory, because this directory belongs into the pkgconfig package(s). This hides broken dependencies in other packages, which expect to pull in pkgconfig by depending on %{_libdir}/pkgconfig.

Note: I haven't checked whether the ownership of directories other than %_libdir/pkgconfig is correct.
Comment 1 Matthew Barnes 2009-05-07 13:03:16 EDT
Fixed in openchange-0.8.2-2-fc11 (and Rawhide).  Thanks.
Comment 2 Fedora Update System 2009-05-07 13:27:17 EDT
openchange-0.8.2-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openchange-0.8.2-2.fc11
Comment 3 Fedora Update System 2009-05-19 20:55:33 EDT
openchange-0.8.2-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.