Bug 499658 - Includes/Provides directory it MUST NOT
Includes/Provides directory it MUST NOT
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ipod-sharp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 11:10 EDT by Michael Schwendt
Modified: 2009-06-16 06:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 06:15:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-05-07 11:10:37 EDT
$ rpmlsv -p ipod-sharp-devel-0.8.1-2.fc11.i586.rpm|grep pkg|grep ^d
drwxr-xr-x root  root         0 /usr/lib/pkgconfig

Your package must not include this directory, because this directory belongs
into the pkgconfig package(s). This hides broken dependencies in other
packages, which expect to pull in pkgconfig by depending on
%{_libdir}/pkgconfig.

Note: I haven't checked whether the ownership of directories other than
%_libdir/pkgconfig is correct.
Comment 1 Bug Zapper 2009-06-09 11:21:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Michael Schwendt 2009-06-14 05:10:02 EDT
Fix committed to devel (F-12), tagged, no build yet.

Note You need to log in before you can comment on or make changes to this bug.