Bug 49968 - tftp server locks up, stops serving files
Summary: tftp server locks up, stops serving files
Status: CLOSED DUPLICATE of bug 46699
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tftp   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-25 18:24 UTC by Ron Flory
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 18:29:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcsh/expect scripts I use to detect/work-around the tftp server problem (948 bytes, application/octet-stream)
2001-07-25 18:29 UTC, Ron Flory
no flags Details

Description Ron Flory 2001-07-25 18:24:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.6 i686)

Description of problem:
Over time, the tftp server stops responding to new 'get' requests,
requiring a restart of xinetd.   I sometimes see a 'connection refused'
message in the syslog, as noted in other bugzilla tftp reports currently in
the database.
Note: same problems exists in tftpd shipped with x86 RH6.2 .

How reproducible:
Sometimes

Steps to Reproduce:
1. issue repeated tftp 'get' requests (for an existing file) with a script
(every 2 seconds)
2. tftp server will not reply to gets.
3. must manually restart xinetd
	

Actual Results:  tftp server evantually locks up.  xinitd reports the tftp
process is being attacked or the process has locked up.  I am not attacking
the server, but the tftp daemon is hosed.

Expected Results:  tftp accept connection, serve file, close, exit. 
repeat.

Additional info:

I will include test scripts (tcsh/expect) that I use to reproduce the
problem, and to automatically restart xinetd when tftp locks up.

Comment 1 Ron Flory 2001-07-25 18:29:03 UTC
Created attachment 24970 [details]
tcsh/expect scripts I use to detect/work-around the tftp server problem

Comment 2 Phil Knirsch 2001-07-30 12:14:36 UTC
Sounds very similar to the other mentioned bug. I'm already looking into it and
will close the other one as soon as i've fixed the problem.

Read ya, Phil

*** This bug has been marked as a duplicate of 46699 ***


Note You need to log in before you can comment on or make changes to this bug.