Bug 499707 - sound card driver loaded but sound card not recognized?
sound card driver loaded but sound card not recognized?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 14:15 EDT by James Ralston
Modified: 2009-05-13 22:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 22:45:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from "alsa-info.sh" (11.14 KB, text/plain)
2009-05-07 14:15 EDT, James Ralston
no flags Details

  None (edit)
Description James Ralston 2009-05-07 14:15:50 EDT
Created attachment 342905 [details]
output from "alsa-info.sh"

I loaded Fedora 11 Preview on my laptop. Although the sound card appears to be recognized (e.g., it's listed in /proc/asound), all utilities behave as if there is no sound card present in the system.

E.g.:

$ alsactl init
alsactl: init:1708: No soundcards found...

$ alsamixer -c0
wrong -c argument '0'

Note that the "alsa-info.sh" output claims that pulseaudio isn't running, but that is most decided false:

$ pulseaudio 
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.

$ ps fax | grep pulse
 3967 ?        Ssl    0:00 /usr/bin/pulseaudio --start --log-target=syslog
 3968 ?        S      0:00  \_ /usr/libexec/pulse/gconf-helper
Comment 1 Matthias Clasen 2009-05-07 17:18:42 EDT
> Note that the "alsa-info.sh" output claims that pulseaudio isn't running, but
> that is most decided false:

That seems to be a bug in the alsa-info.sh script. I see the same. It is doing
pgrep /usr/bin/pulseaudio, which yields nothing.

Either 'pgrep pulseaudio' or 'pgrep -f /usr/bin/pulseaudio' would work.

Might be good to file a bug against alsa-utils about that.
Comment 2 Lennart Poettering 2009-05-07 17:48:51 EDT
Seems to be an ALSA problem. 

Could you please attach the strace output of 'amixer -c0' here?
Comment 3 James Ralston 2009-05-13 22:45:42 EDT
The last batch of updated alsa packages in Rawhide (1.0.18-3.fc11) seems to have fixed this. For now, I'm going to close with RAWHIDE; if I see problems again, I'll reopen and provide "amixer -c0" output.

(The bad use of pgrep was also fixed in the latest alsa-utils.)

Note You need to log in before you can comment on or make changes to this bug.