Bug 499754 - incorrect removable status for PCMCIA to CF adapter
incorrect removable status for PCMCIA to CF adapter
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 19:45 EDT by Peter F. Patel-Schneider
Modified: 2009-05-18 19:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 19:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hal entries for the PCMCIA device and partition and then for a USB device and partition (8.77 KB, text/plain)
2009-05-07 19:45 EDT, Peter F. Patel-Schneider
no flags Details
udev info for PCMCIA CF storage device and then for a USB storage device (for comparison) (8.95 KB, text/plain)
2009-05-07 19:46 EDT, Peter F. Patel-Schneider
no flags Details

  None (edit)
Description Peter F. Patel-Schneider 2009-05-07 19:45:56 EDT
Created attachment 342953 [details]
hal entries for the PCMCIA device and partition and then for a USB device and partition

Description of problem:

Hal appears to have incorrect information concerning a PCMCIA to CF adapter.  It seems to think that the CF card is ejectable from the adapter, when it really isn't.

Version-Release number of selected component (if applicable):

hal 0.5.12 under F11 rawhide as of 7 May 2009

How reproducible:

always


Steps to Reproduce:
1. Plug PCMCIA to CF adapter into slot (on ThinkPad T60p)
  
Actual results:

Nautilus shows a floppy drive-like icon (instead of a disk icon) on the desktop and has an eject entry in the menu, which causes the partition to go away but then come back.
The hal entry for the device has storage.removable = true, as opposed to USB storage devices.  This probably comes from the udev information, which has a similar difference.

Expected results:

The device should look much more like a USB storage device.

Additional info:

None, but at least the device works right now.  (These devices were broken in F9 and probably in other Fedora versions.)

I'm putting this on udev, but maybe the root cause is somewhere lower down in the support structure.  I've included the hal entries for the device and partition along with entries for a USB-connected drive and udev information for these as well.
Comment 1 Peter F. Patel-Schneider 2009-05-07 19:46:59 EDT
Created attachment 342954 [details]
udev info for PCMCIA CF storage device and then for a USB storage device (for comparison)
Comment 2 Harald Hoyer 2009-05-08 06:10:44 EDT
most of the attributes are provided by the kernel
Comment 3 Peter F. Patel-Schneider 2009-05-08 08:18:51 EDT
Is there then any other information that would be useful for me to provide?
Comment 4 Chuck Ebbert 2009-05-09 18:18:09 EDT
CF adapters do support removable media in general. There's no real way to tell if any particular model allows it... and you could insert yours without any media inside.
Comment 5 Peter F. Patel-Schneider 2009-05-09 19:25:05 EDT
Umm, well, I guess so, but are there any CF adapters that can actually eject the media in response to a software command?  This appears to be what Nautilus is picking up on.

The general idea is that Nautilus shouldn't have a eject menu item if there isn't a useful thing to be done in response to the eject.  Nautilus appears to be interpreting "removable" as "software ejectable".

That said, the most unusual behaviour has changed (eject no longer has the partition being remounted) so I can live with the current situation.

Is there a place where the meaning of these udev and hal attributes is written down?
Comment 6 Peter F. Patel-Schneider 2009-05-18 19:39:24 EDT
I don't think that there is anything really to do, except marvel at the strangeness of "removable" reporting from devices. so this "bug" can be closed.

Note You need to log in before you can comment on or make changes to this bug.