Bug 499781 - Duplicate network startup in the init scripts during boot from iSCSI target
Duplicate network startup in the init scripts during boot from iSCSI target
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks: 557926
  Show dependency treegraph
 
Reported: 2009-05-08 02:23 EDT by Wade Mealing
Modified: 2011-01-13 19:05 EST (History)
9 users (show)

See Also:
Fixed In Version: mkinitrd-5.1.19.6-64
Doc Type: Bug Fix
Doc Text:
Previously, network devices could be set up more than once with iSCSI when the system had two partitions on a single iscsi device. With this update, the network is only configured once. This issue could be resolved thanks to the patch contributed made by Thomas Chenault.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 19:05:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2009-05-08 02:23:42 EDT
Description of problem:

When creating the initrd image and the system has two partitions on a single iscsi device, the network section is created twice in the init script.

Version-Release number of selected component (if applicable):

mkinitrd-5.1.19.6-44

How reproducible:

Evey time

Steps to Reproduce:
1. Create two partitions on one iscsi device
2. Rebuild initrd
3. Reboot machine
  
Actual results:

Network is configured twice in the initrd.


Expected results:

Network only to be configured once.

Additional info:

Patch is provided and tested by  

Thomas Chenault to be attached.
Comment 7 RHEL Product and Program Management 2010-07-01 23:09:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Alexander Todorov 2010-07-12 10:45:39 EDT
(In reply to comment #0)
> Description of problem:
> 
> When creating the initrd image and the system has two partitions on a single
> iscsi device, the network section is created twice in the init script.
> 

Hi Wade,
with mkinitrd-5.1.19.6-61 (RHEL5.5) I can't reproduce. I have /home and / on a single iSCSI disk and /boot and swap on a local disk. The original initrd created during install contains the networking section only once. Then I've created a second initrd.img by running: mkinitrd -f test.initrd $(uname -r)
This also has the networking section specified only once. 

Are you able to reproduce this with latest RHEL5 release and if yes what are your steps to reproduce?
Comment 9 Wade Mealing 2010-07-14 02:42:09 EDT
I think it creates as many paths as required to the root volume.  I have a sosreport from the customer, although I've forgotten exactly what it took to reproduce it, besides the above.

I can get a sysreport from the customer if that will assist you.  This reproduced on RHEL 5.4 , if you want I can try again on RHEL 5.5 but I didn't see anything in that script that would change the behaviour.

Wade.
Comment 10 Alexander Todorov 2010-07-14 07:02:00 EDT
Please ask the customer to test with 5.5 and attach sosreport and any other information that may be useful.
Comment 12 John Feeney 2010-09-10 16:30:21 EDT
Can anyone provide the testing feedback requested by comment #10?

Thanks in advance.
Comment 14 Peter Jones 2010-09-24 12:17:02 EDT
Should be fixed in mkinitrd-5.1.19.6-64 .
Comment 16 Jan Stodola 2010-10-04 03:56:18 EDT
Retested with mkinitrd-5.1.19.6-65.el5 using steps from comment 13. Network started only once during the initrd initialization. Build: RHEL5.6-Server-20100930.0.

Moving to VERIFIED.
Comment 18 Florian Nadge 2011-01-03 10:46:37 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, network devices could be set up more than once with iSCSI when the system had two partitions on a single iscsi device. With this update, the network is only configured once. This issue could be resolved thanks to the patch contributed made by Thomas Chenault.
Comment 20 errata-xmlrpc 2011-01-13 19:05:34 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0110.html

Note You need to log in before you can comment on or make changes to this bug.