Bug 499803 - F10 crashes on Intel Atom caused by a processor bug
F10 crashes on Intel Atom caused by a processor bug
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 494596 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 06:04 EDT by Carl-Johan Kjellander
Modified: 2009-05-25 17:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.6.27.24-170.2.68.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 17:10:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl-Johan Kjellander 2009-05-08 06:04:42 EDT
Description of problem:
Creating a USB Live stick with livecd-iso-to-disk, the resulting live image won't boot properly.

Version-Release number of selected component (if applicable):
Several, both the original F10 Live image and ones created with livecd-creator.

How reproducible:
95%

Steps to Reproduce:
1. Create a F10 Live image or download F10 Live iso
2. Create a usb image of it with livecd-creator
3. Try to boot it on Intel D945GCLF
  
Actual results:
95% of the time it randomly panics or hangs, never in the same place.

Expected results:
1 in 20 it actually comes up with a full desktop, as expected.

Additional info:
We've used F7 in the past with the exact same system, and it works fine. But we obviously want to use a later version.

The weird thing is that even though this is a totally diskless system, the panics and hangs are seemingly happening at random during the boot.
Comment 1 Chuck Ebbert 2009-05-09 02:39:31 EDT
This is a processor bug (Intel Atom erratum AAH41). Either update your BIOS or update the kernel to 2.6.29.2-52 from updates-testing.
Comment 2 Chuck Ebbert 2009-05-20 20:51:06 EDT
A backport of that fix is in kernel-2.6.27.24-170.2.66
Comment 3 Chuck Ebbert 2009-05-20 21:09:30 EDT
*** Bug 494596 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2009-05-22 05:02:20 EDT
kernel-2.6.27.24-170.2.68.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kernel-2.6.27.24-170.2.68.fc10
Comment 5 Fedora Update System 2009-05-25 17:09:48 EDT
kernel-2.6.27.24-170.2.68.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.