This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 499818 - More prominent documentation of cman and split brain.
More prominent documentation of cman and split brain.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Programming_Reference (Show other bugs)
beta
All Linux
high Severity medium
: 1.3
: ---
Assigned To: Alison Young
MRG Quality Engineering
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 08:28 EDT by Alan Conway
Modified: 2012-09-21 08:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 22:02:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2009-05-08 08:28:34 EDT
A customer have suggested we make the documentation of the --qpid-cman option and the discussion of handling "split-brain" issues more prominent, since many/most cluster users will need split-brain protection. The custome didn't initially understand the requirement for cman from their initial reading of the doc.
Comment 2 Jonathan Robie 2009-09-09 11:20:27 EDT
I've added the following text:

For most applications, High Availability Messaging Clusters should be used together with Red Hat Clustering Services (RHCS) to avoid the "split-brain" condition, in which a network failure splits the cluster into two sub-clusters that cannot communicate with each other. See the documentation on the --cluster-cman option for details on running using RHCS with High Availability Messaging Clusters. See the CMAN documentation for more detail on CMAN and split-brain conditions.
Comment 3 Alan Conway 2009-09-10 09:53:18 EDT
I'd make it a bit stronger and add:

Without CMAN, a cluster cannot recover from a split-brain condition. If the network problem is resolved and the sub-clusters start communicating again the results are unpredictable.
Comment 5 Alison Young 2011-03-16 22:02:09 EDT
Closed as fix already implemented

Note You need to log in before you can comment on or make changes to this bug.