Bug 499846 - Provisioning, unable to kickstart rhel 4 nonvirt due to package error
Provisioning, unable to kickstart rhel 4 nonvirt due to package error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://riverraid.rhndev.redhat.com/r...
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-05-08 10:51 EDT by wes hayutin
Modified: 2009-09-10 15:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart_error_message (169.75 KB, image/png)
2009-07-29 15:01 EDT, John Sefler
no flags Details

  None (edit)
Description wes hayutin 2009-05-08 10:51:34 EDT
Description of problem:

5/7.1 build rhel 5 server

1. register rhel 4 client
2. enable provisioning, create ks profile
3. provisioning, schedule kickstart...

get error

A kickstart was not scheduled for fjs-0-19.rhndev.redhat.com because the package profile did not contain the 'up2date' package. An update of that system's package profile may be required.

client has package
[root@fjs-0-19 ~]# rpm -q up2date
up2date-4.8.1-33.el4
[root@fjs-0-19 ~]#
Comment 1 wes hayutin 2009-05-08 10:57:53 EDT
registered anothe rhel 4 box, and did not see the error.. again looks like possible errors w/ sync profile :(b
Comment 2 Justin Sherrill 2009-06-03 12:41:58 EDT
Hrm, so i wasn't able to reproduce.  Are you able to wes?
Comment 3 wes hayutin 2009-06-03 13:02:02 EDT
I think this problem has been fixed.. moving to on_qa
Comment 4 wes hayutin 2009-06-04 09:09:37 EDT
I actually did recreate this, but its easily fixed by running up2date -p or rhn-profile-sync.  I suspect its a problem w/ the initial registration of systems and their package profile.

recreate:  use perl to provision rhel 4 boxes.. Try a fjs box
then register to satellite
check package list for up2date package. or run a kickstart
Comment 5 Justin Sherrill 2009-06-05 15:12:32 EDT
Wes, what u release are you provisioning these too ?
Comment 6 wes hayutin 2009-06-08 12:50:10 EDT
could not recreate in 6/5 w/ same hardware, same testplan..

use perl to ks fjs-0-12 to rhel4-u7
register to grandprix
ks fjs-0-12
could not get up2date pkg error
Comment 7 John Sefler 2009-07-29 15:01:20 EDT
Created attachment 355598 [details]
kickstart_error_message
Comment 8 John Sefler 2009-07-29 15:02:54 EDT
I was able to re-create the problem exactly as originally described in the problem description.  I am attaching screenshot "kickstart_error_message" as proof.
My client was:

[root@fjs-0-12 ~]# uname -a
Linux fjs-0-12.rhndev.redhat.com 2.6.9-89.EL #1 Mon Apr 20 10:23:08 EDT 2009 i686 i686 i386 GNU/Linux
[root@fjs-0-12 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 8)
[root@fjs-0-12 ~]# rpm -q up2date
up2date-4.8.1-33.el4
[root@fjs-0-12 ~]# rpm -q kernel
kernel-2.6.9-89.EL

moving to FAILS_QA
Comment 9 Justin Sherrill 2009-07-29 15:09:43 EDT
Hi John,

This is a bug with the RHEL4u8 client packages.  Basically those client packages do not include the 'up2date' packages in its package profile.  If you run 'up2date -p' on the client, it should correct that error.

Flipping back to ON_QA.

-Justin
Comment 10 John Sefler 2009-07-29 16:02:46 EDT
as suggested in Comment #9....
[root@fjs-0-12 ~]# up2date -p
Updating package profile...
Updating transaction history...

After running 'up2date -p' on the client, I was successfuly able to kickstart the RHEL4 system back to RHEL3.

moving to RELEASE_PENDING
Comment 11 Brandon Perkins 2009-09-10 15:25:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.