Bug 499852 - SELinux alerts with fprint auth in Fedora 11
SELinux alerts with fprint auth in Fedora 11
Status: CLOSED DUPLICATE of bug 499513
Product: Fedora
Classification: Fedora
Component: fprintd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 11:28 EDT by Tom "spot" Callaway
Modified: 2009-05-08 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 11:37:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2009-05-08 11:28:15 EDT
I use fprint to authenticate via gdm (fingerprint auth), and upon reboot today, I noticed that SELinux threw some audit messages about what it would have denied if I wasn't in permissive.

SELinux is preventing fprintd (fprintd_t) "read" var_lib_t. 
SELinux is preventing fprintd (fprintd_t) "getattr" var_lib_t. 

Policy RPM:  selinux-policy-3.6.12-28.fc11
Selinux Enabled:  True
Policy Type:  targeted
MLS Enabled:  True
Enforcing Mode:  Permissive
Plugin Name:  catchall

Raw Audit Messages :
node=velociraptor type=AVC msg=audit(1241795965.507:19): avc: denied { getattr } for pid=2903 comm="fprintd" path="/var/lib/fprint/spot/0001/00000000/7" dev=sda3 ino=1581469 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_lib_t:s0 tclass=file 

node=velociraptor type=SYSCALL msg=audit(1241795965.507:19): arch=c000003e syscall=5 success=no exit=-1378041896 a0=a a1=7fff07b3fe00 a2=7fff07b3fe00 a3=3030303030302f31 items=0 ppid=1 pid=2903 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="fprintd" exe="/usr/libexec/fprintd" subj=system_u:system_r:fprintd_t:s0-s0:c0.c1023 key=(null) 

Raw Audit Messages :
node=velociraptor type=AVC msg=audit(1241795965.507:18): avc: denied { read } for pid=2903 comm="fprintd" name="7" dev=sda3 ino=1581469 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_lib_t:s0 tclass=file 

node=velociraptor type=AVC msg=audit(1241795965.507:18): avc: denied { open } for pid=2903 comm="fprintd" name="7" dev=sda3 ino=1581469 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_lib_t:s0 tclass=file 

node=velociraptor type=SYSCALL msg=audit(1241795965.507:18): arch=c000003e syscall=2 success=no exit=-1378041896 a0=151a730 a1=0 a2=0 a3=3030303030302f31 items=0 ppid=1 pid=2903 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="fprintd" exe="/usr/libexec/fprintd" subj=system_u:system_r:fprintd_t:s0-s0:c0.c1023 key=(null)
Comment 1 Daniel Walsh 2009-05-08 11:37:46 EDT

*** This bug has been marked as a duplicate of bug 499513 ***

Note You need to log in before you can comment on or make changes to this bug.