Bug 499853 - nagios: update to version 3.1.x (3.1.2)
nagios: update to version 3.1.x (3.1.2)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nagios (Show other bugs)
12
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 11:29 EDT by Jose Pedro Oliveira
Modified: 2010-02-25 05:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-25 05:11:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the nagios specfile 3.1.2-2 (2.45 KB, patch)
2009-07-24 12:54 EDT, Jose Pedro Oliveira
no flags Details | Diff

  None (edit)
Description Jose Pedro Oliveira 2009-05-08 11:29:51 EDT
Description of problem:
Nagios 3.1.0 has been released in January:

Changelog:
http://www.nagios.org/development/history/nagios-3x.php
Comment 1 Jose Pedro Oliveira 2009-05-08 11:36:10 EDT
A couple of days ago a fork of Nagios has been announced with the first release schedule to the end of the month:

Further reading:

 * Nagios forks to ICINGA
   http://www.h-online.com/open/Nagios-forks-to-ICINGA--/news/113225

 * ICINGA homepage
   http://www.icinga.org/

 * Why a fork?
   http://www.icinga.org/why-a-fork/

/jpo
Comment 2 Jose Pedro Oliveira 2009-05-21 16:42:22 EDT
First beta of Icinga is available (Icinga v0.8.0)
Comment 3 Bug Zapper 2009-06-09 11:27:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jose Pedro Oliveira 2009-06-29 14:06:22 EDT
 * Changing version to rawhide.

 * The latest Nagios release is 3.1.2
   http://www.nagios.org/download/core/

   Changelog
   http://www.nagios.org/development/history/core-3x

 * The latest Icinga version is 0.8.1
   http://www.icinga.org/2009/06/17/icinga-081-released/
Comment 5 Jose Pedro Oliveira 2009-07-02 17:35:29 EDT
This last changelog entry in devel/nagios.spec is incorrect:

----
...
* Mon Jun 29 2009  Robert M. Albrecht <fedora@romal.de> 3.2.1-1
- Upstream released a new version
...
----

The version should be 3.1.2 (and not 3.2.1).

/jpo
Comment 6 Jose Pedro Oliveira 2009-07-23 15:40:28 EDT
Could someone correct the last two changelog entries in devel/nagios.spec ?
They are incorrect:


$ cvs diff -u devel/nagios.spec 
Index: devel/nagios.spec
===================================================================
RCS file: /cvs/pkgs/rpms/nagios/devel/nagios.spec,v
retrieving revision 1.71
diff -u -r1.71 nagios.spec
--- devel/nagios.spec   15 Jul 2009 18:55:01 -0000      1.71
+++ devel/nagios.spec   23 Jul 2009 19:37:35 -0000
@@ -203,10 +203,10 @@
 %{_includedir}/%{name}
 
 %changelog
-* Wed Jul 15 2009 Mike McGrath <mmcgrath@redhat.com> 3.2.1-2
+* Wed Jul 15 2009 Mike McGrath <mmcgrath@redhat.com> 3.1.2-2
 - Release bump for rebuild
 
-* Mon Jun 29 2009  Robert M. Albrecht <fedora@romal.de> 3.2.1-1
+* Mon Jun 29 2009  Robert M. Albrecht <fedora@romal.de> 3.1.1-1
 - Upstream released a new version
 
 * Mon Jun 22 2009 Mike McGrath <mmcgrath@redhat.com> - 3.0.6-4
Comment 7 Jose Pedro Oliveira 2009-07-24 08:50:08 EDT
Other problems in nagios-3.1.2-2.fc12.i586.rpm:


 * wrong physical_html_path value in cgi.cfg (second time)

   WRONG: physical_html_path=/usr/share/nagios/share
   RIGHT: physical_html_path=/usr/share/nagios/html

   Solution:
   Commit the following change to the specfile (s/datadir/datarootdir/)

   ----
   -        --datadir=%{_datadir}/%{name}/html \
   +       --datarootdir=%{_datadir}/%{name}/html \
   ----


 * new php configuration file can't be read by Apache (breaks the web interface)

   $ rpm -qplv nagios-3.1.2-2.fc12.i586.rpm | grep config.inc.php
   -rw------- 1 root  root 545 Jul 15 19:59 /usr/share/nagios/html/config.inc.php

   Add the following line to the %files section
   ---
    %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/.htpasswd
   +%attr(0640,root,apache) %config(noreplace) %{_datadir}/%{name/html/config.inc.php
    %attr(0755,nagios,nagios) %dir %{_localstatedir}/spool/%{name}
   ---


/jpo
Comment 8 Jose Pedro Oliveira 2009-07-24 08:52:03 EDT
Increased the priority and severity due to the problems reported in the previous comment.
Comment 9 Mike McGrath 2009-07-24 09:10:07 EDT
Do you just want to co-maintain this package?  I've been thinking about orphaning it since we're moving away from it?
Comment 10 Jose Pedro Oliveira 2009-07-24 12:49:49 EDT
(In reply to comment #9)
> Do you just want to co-maintain this package?  I've been thinking about
> orphaning it since we're moving away from it?  

Just curious. What package are you planning to use as Nagios replacement?

/jpo
Comment 11 Jose Pedro Oliveira 2009-07-24 12:54:26 EDT
Created attachment 355069 [details]
Patch to the nagios specfile 3.1.2-2

Mike,

Could you apply this patch to the specfile in the development branch?

It also re-enables the httpd requirement as its dismissal causes at least two problems (https://bugzilla.redhat.com/show_bug.cgi?id=487411).  We need to split the nagios package a couple more times to solve the httpd dependency (and also solve the nagios-plugins problems with the nagios account).

/jpo
Comment 12 mail@romal.de 2009-07-24 15:04:26 EDT
I updated and build it for rawhide, but I really don't understand why it wouldn't build for f-11.

The tar is uploaded but koji keeps complaining.

[romal@localhost F-11]$ make new-sources FILES="nagios-3.1.2.tar.gz" 

Checking : nagios-3.1.2.tar.gz on https://cvs.fedoraproject.org/repo/pkgs/upload.cgi...
This file (f3c60428cba14264c709749182b8d93e  nagios-3.1.2.tar.gz) is already uploaded

Source upload succeeded. Don't forget to commit the new ./sources file
[romal@localhost F-11]$ cvs diff -u

cvs diff: Diffing .
[romal@localhost F-11]$ 
[romal@localhost F-11]$ cvs commit
cvs commit: Examining .
[romal@localhost F-11]$ 

Koji tells me: 

error: File /builddir/build/SOURCES/nagios-3.1.2.tar.gz: No such file or directory
Comment 13 Jose Pedro Oliveira 2009-07-24 17:15:18 EDT
(In reply to comment #12)

Didn't you tagged the F-11 branch before updating the sources file?


----------
$ cvs log F-11/sources | head

RCS file: /cvs/pkgs/rpms/nagios/F-11/sources,v
Working file: F-11/sources
head: 1.20
branch:
locks: strict
access list:
symbolic names:
        nagios-3_1_2-3_fc11: 1.19
        F-11-start: 1.19
        ...
----------

Notes:
   Tagged revision 1.19
   Current revision 1.20


----------
$ cvs diff -r 1.19 F-11/sources 
Index: F-11/sources
===================================================================
RCS file: /cvs/pkgs/rpms/nagios/F-11/sources,v
retrieving revision 1.19
retrieving revision 1.20
diff -r1.19 -r1.20
1c1
< 900e3f4164f4b2a18485420eeaefe812  nagios-3.0.6.tar.gz
---
> f3c60428cba14264c709749182b8d93e  nagios-3.1.2.tar.gz
----------
Comment 14 mail@romal.de 2009-08-02 05:41:12 EDT
May be. How do I correct this ?
Comment 15 Jose Pedro Oliveira 2009-08-02 11:04:36 EDT
(In reply to comment #14)
> May be. How do I correct this ?  

Detailing the operations mentioned in
https://bugzilla.redhat.com/show_bug.cgi?id=476635#c4


 * bump the F-11 specfile release without breaking the distro upgrade path
   ( Release: 3%{?dist}.1 )

 * commit the changes to the specfile

 * check the contents of the files .cvsignore and sources

 * check that everything is committed

 * tag the F-11 directory files

 * request a build 

/jpo
Comment 16 Mike McGrath 2009-08-17 22:19:38 EDT
FYI, 3.2 should be available in rawhide soon.
Comment 17 Bug Zapper 2009-11-16 04:58:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Bill McGonigle 2010-02-11 22:25:43 EST
I've got nagios-3.2.0-3.fc12.x86_64 here, is this bug still valid?
Comment 19 Peter Lemenkov 2010-02-25 05:11:15 EST
Nagios package for ver. 3.2.0 already available, so I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.