Bug 499906 - numpy rpm in F11 Preview missing core.distutils
numpy rpm in F11 Preview missing core.distutils
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-08 15:48 EDT by m
Modified: 2009-05-11 09:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 15:56:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description m 2009-05-08 15:48:33 EDT
Description of problem: The rpm shipped in F11 Preview is missing some files


Version-Release number of selected component (if applicable): numpy-1.3.0-1.i386


How reproducible: always


Steps to Reproduce:
1. python
2. from numpy.distutils.core import setup
3.
  
Actual results:
ImportError

Expected results:


Additional info:
getting the source from numpy website and building the rpm with:
python setup bdist_rpm
does produce a 'complete' rpm, so it looks like a packaging issue.
Comment 1 Rex Dieter 2009-05-08 15:56:51 EDT
yum install numpy-f2py
to get the bits you want.

See bug #494113 for background on the split.
Comment 2 m 2009-05-08 16:27:52 EDT
Ok, thanks.
Shouldn't numpy-f2py be called numpy-devel ? the distutils stuff not just Fortran.
Comment 3 Gwyn Ciesla 2009-05-11 09:07:35 EDT
I could just move distutils back to the main package.  Any objections?  -devel seems redundant for this package.

Note You need to log in before you can comment on or make changes to this bug.