Bug 499937 - Useless alert pluging truecrypt harddisk.
Useless alert pluging truecrypt harddisk.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libatasmart (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 03:14 EDT by Bernhard Schuster
Modified: 2009-05-10 14:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-10 14:55:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of popup/icon (37.81 KB, image/png)
2009-05-10 06:02 EDT, Bernhard Schuster
no flags Details
mountinfo (1.19 KB, text/plain)
2009-05-10 06:06 EDT, Bernhard Schuster
no flags Details
devkit-disks --dump (29.14 KB, text/plain)
2009-05-10 06:07 EDT, Bernhard Schuster
no flags Details
gvfs-mount -li (1.45 KB, text/plain)
2009-05-10 06:07 EDT, Bernhard Schuster
no flags Details

  None (edit)
Description Bernhard Schuster 2009-05-09 03:14:32 EDT
Description of problem:
Encrypted volumes by truecrypt always show as malfunctioning filesystems.


Version-Release number of selected component (if applicable):
Version    : 0.3
Ausgabe    : 1.fc11

How reproducible:
Always

Steps to Reproduce:
1. External disk, at least one encrypted partition
2. restart fedora
3. see that popup apear after gdm log in.
  
Actual results:
Error message and nasty icon

Expected results:
Nothing being said.

Additional info:
Comment 1 David Zeuthen 2009-05-09 10:00:05 EDT
(In reply to comment #0)
> Description of problem:
> Encrypted volumes by truecrypt always show as malfunctioning filesystems.

[...]

> Actual results:
> Error message and nasty icon

Do you think you can be a bit more specific here? Please attach a screenshot.

Also attach the information requested in the first three bullet points from this page

http://www.freedesktop.org/wiki/Software/DeviceKit-disks

Thanks.
Comment 2 Bernhard Schuster 2009-05-10 06:01:36 EDT
I have external harddisk encrypted with truecrypt 6.x, one big tripple encrypted partition. Whenever I plug in the disk, this orange error disk-icon appears in my taskbar, telling me the disk is broken/has errors, because of the fact of an unknown formating / encryption. (See screenshot)
Comment 3 Bernhard Schuster 2009-05-10 06:02:33 EDT
Created attachment 343254 [details]
screenshot of popup/icon
Comment 4 Bernhard Schuster 2009-05-10 06:06:22 EDT
Created attachment 343255 [details]
mountinfo
Comment 5 Bernhard Schuster 2009-05-10 06:07:03 EDT
Created attachment 343256 [details]
devkit-disks --dump
Comment 6 Bernhard Schuster 2009-05-10 06:07:24 EDT
Created attachment 343257 [details]
gvfs-mount -li
Comment 7 David Zeuthen 2009-05-10 14:55:07 EDT
(In reply to comment #2)
> I have external harddisk encrypted with truecrypt 6.x, one big tripple
> encrypted partition. Whenever I plug in the disk, this orange error disk-icon
> appears in my taskbar, telling me the disk is broken/has errors, because of the
> fact of an unknown formating / encryption. (See screenshot)  

What makes you think that this has anything to do with the fact you are using truecrypt (it hasn't)? According to the SMART data reported by the disk, the disk has bad sectors, e.g.

> reallocated-sector-count     37/ 37/ 10   FAIL    591 sectors Prefail  Online 

and that's why we show you this icon. So the warning about your disk failing is indeed warranted and this is not a bug - it's _supposed_ to work this way.

If this was my disk, I'd backup all the data and move it over to another disk.

See http://en.wikipedia.org/wiki/Self-Monitoring,_Analysis,_and_Reporting_Technology#Known_ATA_S.M.A.R.T._attributes for more information.

Moving to libatasmart and closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.