Bug 499942 - PATCH: alsa output plugin fixes
PATCH: alsa output plugin fixes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: audacious-plugins (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
: 498885 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 06:25 EDT by Hans de Goede
Modified: 2009-06-26 22:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.5.1-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 22:45:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa plugin: Fix last second(s) of songs getting lost (2.90 KB, patch)
2009-05-12 14:33 EDT, Hans de Goede
no flags Details | Diff
Fix alsa plugin locking (5.14 KB, patch)
2009-05-12 14:34 EDT, Hans de Goede
no flags Details | Diff
alsa output plugin: allow usage of last byte of thread buffer (2.96 KB, patch)
2009-05-12 14:34 EDT, Hans de Goede
no flags Details | Diff
alsa output plugin: use snd_pcm_recover() (2.49 KB, patch)
2009-05-12 14:35 EDT, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2009-05-09 06:25:41 EDT
I've recently been digitizing my music collection and I'm using audacious to
play it. While using audacious I've noticed 2 issues with the alsa output plugin:

1) The last buffersize seconds of a song are not played
2) Its locking is wrong, together with a recent rawhide pulseaudio update
   this causes audacious to hang at the beginning of a song once every while
   (quite often on one of my systems, less often on another)

I've written 2 patches fixing this, you can find these in this upstream ticket:
http://redmine.atheme.org/issues/show/60
Comment 1 Hans de Goede 2009-05-12 14:32:32 EDT
Ok, so I've been testing this some more and my second patch attached to:
http://redmine.atheme.org/issues/show/60

Had some issues, I've filed a new set of patches here:
http://redmine.atheme.org/issues/show/61

However those are against the 2.0 mercurial tree. I initially developed them
against 1.5.1, so I'll attach the original versions here. Please apply these
do the Fedora package, without them when using the alsa output with the latest pulse alsa plugin (which is the default setup). audacious often hangs (on my system). The locking in the alsa output plugin without this patch is non existent, and that while there are separate reader / writer threads both manipulating the rd / wr indexes of a fifo.
Comment 2 Hans de Goede 2009-05-12 14:33:31 EDT
Created attachment 343642 [details]
alsa plugin: Fix last second(s) of songs getting lost
Comment 3 Hans de Goede 2009-05-12 14:34:02 EDT
Created attachment 343643 [details]
Fix alsa plugin locking
Comment 4 Hans de Goede 2009-05-12 14:34:35 EDT
Created attachment 343644 [details]
alsa output plugin: allow usage of last byte of thread buffer
Comment 5 Hans de Goede 2009-05-12 14:35:34 EDT
Created attachment 343645 [details]
alsa output plugin: use snd_pcm_recover()

This last patch is a bit of an optional cleanup I did while I was at it.
Comment 6 Michael Schwendt 2009-06-05 03:15:27 EDT
*** Bug 498885 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2009-06-05 08:10:38 EDT
audacious-plugins-1.5.1-6.fc10,audacious-1.5.1-9.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/audacious-plugins-1.5.1-6.fc10,audacious-1.5.1-9.fc10
Comment 8 Bug Zapper 2009-06-09 11:31:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2009-06-15 22:37:50 EDT
audacious-plugins-1.5.1-6.fc11, audacious-1.5.1-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6438
Comment 10 Fedora Update System 2009-06-15 22:45:22 EDT
audacious-plugins-1.5.1-6.fc10, audacious-1.5.1-9.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6490
Comment 11 Fedora Update System 2009-06-26 22:44:30 EDT
audacious-plugins-1.5.1-6.fc11, audacious-1.5.1-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-06-26 22:46:44 EDT
audacious-plugins-1.5.1-6.fc10, audacious-1.5.1-9.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.