Bug 499953 - SeLinux preventing the launce of gnome-system-monitor even though SeLinux is disabled
SeLinux preventing the launce of gnome-system-monitor even though SeLinux is ...
Product: Fedora
Classification: Fedora
Component: gnome-system-monitor (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-05-09 09:38 EDT by Joshua Rosen
Modified: 2014-06-18 05:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 12:27:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2009-05-09 09:38:18 EDT
Description of problem:
I'm getting a policy kit error when I launch gnome-system-monitor even though I have SeLinux disabled. I tried enabling and then disabling SeLinux again and then rebooting, that did't fix it.

Version-Release number of selected component (if applicable):

How reproducible:100%

Steps to Reproduce:
1.launch gnome-system-monitor
Actual results:
[WARN  4092] polkit-error.c:143:polkit_error_get_error_message(): error != NULL
 Not built with -rdynamic so unable to print a backtrace

** (gnome-system-monitor:4092): WARNING **: Failed to initialize PolicyKit context: (null)
[WARN  4092] polkit-error.c:156:polkit_error_free(): error != NULL
 Not built with -rdynamic so unable to print a backtrace

Expected results:

Additional info:
Comment 1 Daniel Walsh 2009-05-11 08:00:17 EDT
I don't believe this is an SELinux issue.
Comment 2 Joshua Rosen 2009-05-11 08:18:41 EDT
If it's not an SELinux issue why is it giving a Policy Kit error? BTW I tried uninstalling and reinstalling gnome-system-monitor, that didn't help.
Comment 3 Daniel Walsh 2009-05-11 08:33:30 EDT
Policy Kit is a totally different product/package then SELinux.
Comment 4 Joshua Rosen 2009-05-11 08:52:18 EDT
Do I need to reclassify this bug report or have you already done it?
Comment 5 Daniel Walsh 2009-05-11 09:07:01 EDT
Already reassigned to gnome-system-monitor
Comment 6 Bug Zapper 2009-06-09 23:42:21 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 7 Bug Zapper 2009-07-14 12:27:46 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.