Bug 499967 - anaconda wants to reformat/destroy too many lvm partitions
anaconda wants to reformat/destroy too many lvm partitions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-09 12:49 EDT by Zach Carter
Modified: 2009-06-01 18:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-01 18:53:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vgdisplay -v output (15.29 KB, text/plain)
2009-05-09 12:50 EDT, Zach Carter
no flags Details
storage.log (336.22 KB, text/plain)
2009-05-12 22:16 EDT, Zach Carter
no flags Details
anaconda.log (219.51 KB, text/plain)
2009-05-12 22:17 EDT, Zach Carter
no flags Details
program.log (21.89 KB, text/plain)
2009-05-12 22:17 EDT, Zach Carter
no flags Details
updates with proposed fix (119.18 KB, application/octet-stream)
2009-05-13 20:54 EDT, David Lehman
no flags Details
updates with proposed fix, this time against f11-pre (109.79 KB, application/octet-stream)
2009-05-13 21:09 EDT, David Lehman
no flags Details

  None (edit)
Description Zach Carter 2009-05-09 12:49:24 EDT
Description of problem:

During an install of the F11 preview release (I tried both the live and the dvd versions), anaconda inexplicably decides it wants to reformat some partitions that I didn't ask it to.


Version-Release number of selected component (if applicable):  


How reproducible:

always reproducible for me.


Steps to Reproduce:
1.  In anaconda storage section, select "create custom layout"
2.  select a partition for / to be formatted, use a pre-existing /boot, ignoring all other pre-existing partitions.
  
Actual results:

dialog comes up warning about partitions selected to be formatted, destroying all data:

/dev/mapper/hothvg-f11lv         ext4         /
/dev/mapper/hothvg-home2lv_mimage_0         None         
/dev/mapper/hothvg-home2lv_mimage_1         None         
/dev/mapper/hothvg-homelv_mimage_0         None         
/dev/mapper/hothvg-homelv_mimage_1         None         
/dev/mapper/hothvg-opt3lv_mimage_0         None         
/dev/mapper/hothvg-opt3lv_mimage_1         None         
/dev/mapper/hothvg-optlv_mimage_0         None         
/dev/mapper/hothvg-optlv_mimage_1         None  

Expected results:

It should only be reformatting f11lv, my slash partition, like this:

/dev/mapper/hothvg-f11lv         ext4         /



Additional info:

I don't really know where the mimage volumes came from, but it shouldn't matter.  I shouldn't have to figure that out during the install.  The installer should only reformat things that I specifically chose to format.  I can research where those "mimage" volumes came from after I have the install completed.
Comment 1 Zach Carter 2009-05-09 12:50:53 EDT
Created attachment 343223 [details]
vgdisplay -v output
Comment 2 David Lehman 2009-05-11 16:46:27 EDT
Can you attach the files /tmp/storage.log, /tmp/program.log, and /tmp/anaconda.log?
Comment 3 Zach Carter 2009-05-12 22:16:46 EDT
Created attachment 343678 [details]
storage.log
Comment 4 Zach Carter 2009-05-12 22:17:16 EDT
Created attachment 343679 [details]
anaconda.log
Comment 5 Zach Carter 2009-05-12 22:17:36 EDT
Created attachment 343680 [details]
program.log
Comment 6 Zach Carter 2009-05-12 22:18:01 EDT
(In reply to comment #2)
> Can you attach the files /tmp/storage.log, /tmp/program.log, and
> /tmp/anaconda.log?  

done.
Comment 7 David Lehman 2009-05-13 13:47:46 EDT
Can you generally describe your setup? I see that you have quite a few lvs, and then there are the _mimage_0 and _mlog lvs as well. Do you have some sort of mirroring or other advanced lvm configuration? The reason I am asking is that this does not happen with other lvm setups.
Comment 8 Zach Carter 2009-05-13 14:04:16 EDT
(In reply to comment #7)
> Can you generally describe your setup? I see that you have quite a few lvs, and
> then there are the _mimage_0 and _mlog lvs as well. Do you have some sort of
> mirroring or other advanced lvm configuration? The reason I am asking is that
> this does not happen with other lvm setups.  

I have a bunch of logical volumes, some of them mirrored.  I created most of them with "system-config-lvm".  I did not do anything to create those "mimage" volumes, but I am leery about removing them until I understand where they came from.  If your mirrorlog option is "disk", then those mlog volumes are created (see man lvconvert).

Recently I migrated some data from old disks to a new disk.  In order to do that, I had to temporarily remove some of the "mlog" volumes by changing the mirrorlog type to "core".  After I had moved the data onto the new disk, I changed them back to "disk".  (I had to use the lvconvert command for this, since system-config-lvm has a fatal error if any of your mirrors are using a "core" mirror type, see related bug https://bugzilla.redhat.com/show_bug.cgi?id=494127).

Perhaps those mimage volumes are a by product of that recent migration?  I'm not sure.

Regardless, I don't think anaconda should be doing anything with them.  They have nothing to do with the install I am attempting.
Comment 9 David Lehman 2009-05-13 20:54:53 EDT
Created attachment 343897 [details]
updates with proposed fix
Comment 10 David Lehman 2009-05-13 21:09:30 EDT
Created attachment 343899 [details]
updates with proposed fix, this time against f11-pre

Please try the attached updates image and see if it solves this problem.
(http://fedoraproject.org/wiki/Anaconda/Updates#Updates_from_the_Network)

The same updates image is available here:

  http://dlehman.fedorapeople.org/updates-499967.img

just in case you'd rather grab it from there.
Comment 11 Zach Carter 2009-05-14 00:29:48 EDT
(In reply to comment #10)
> Created an attachment (id=343899) [details]
> updates with proposed fix, this time against f11-pre
> 
> Please try the attached updates image and see if it solves this problem.

Yup, that fixed it.  The install was completed, and anaconda only listed my slash partition to be formatted.

Thanks!

-Zach
Comment 12 David Lehman 2009-05-14 18:44:29 EDT
This will be fixed in anaconda-11.5.0.53-1.

Note You need to log in before you can comment on or make changes to this bug.