Bug 500015 - Ati Driver not working with ATI Radeon HD3850
Ati Driver not working with ATI Radeon HD3850
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 03:42 EDT by Steve
Modified: 2009-07-07 03:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 12:43:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
photo of destroyed picture (3.68 MB, image/jpeg)
2009-05-10 03:42 EDT, Steve
no flags Details
xorg.conf (76.31 KB, text/plain)
2009-05-13 02:33 EDT, Steve
no flags Details

  None (edit)
Description Steve 2009-05-10 03:42:01 EDT
Created attachment 343249 [details]
photo of destroyed picture

Description of problem:
Ati Driver is not working with ATI Radeon HD3850 (AGP). The Monitor shows a destroyed picture instead of GDM. X is not freezing. 

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.2-13.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Have to install xorg-x11-drv-radeonhd to make this card working.

Expected results:
xorg-x11-drv-ati should at least have 2D support.

Additional info:
xorg-x11-drv-ati was working in about Fedora-11-Alpha.
Comment 1 Matěj Cepl 2009-05-12 17:55:21 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below..

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Steve 2009-05-13 02:33:34 EDT
Created attachment 343710 [details]
xorg.conf
Comment 3 Steve 2009-05-13 02:38:53 EDT
There is no xorg.conf anymore. If i switch to xorg-x11-drv-radeonhd, i write the xorg.conf as follow to make the driver working:

Section "Device"
	Identifier "Videocard0"
	Driver "radeonhd"
EndSection
Comment 4 Steve 2009-05-13 02:40:39 EDT
Sorry, the attachment is Xorg.0.log and not xorg.conf.
Comment 5 Bug Zapper 2009-06-09 11:35:09 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Steve 2009-06-24 04:32:28 EDT
Semms to be fixed in xorg-x11-drv-ati-6.12.2-18.fc12.i586
Comment 7 Matěj Cepl 2009-06-26 12:43:27 EDT
Thanks for letting us know.
Comment 8 Steve 2009-07-06 03:58:44 EDT
Please reopen this bug because it was only fixed for rawhide, and not for Fedora-11!
Comment 9 Steve 2009-07-07 03:49:55 EDT
Made a new one -> https://bugzilla.redhat.com/show_bug.cgi?id=509967

Note You need to log in before you can comment on or make changes to this bug.