Bug 500065 - hp-setup crash
hp-setup crash
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
10
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 11:28 EDT by Alexey Kuznetsov
Modified: 2009-07-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-01 11:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2009-05-10 11:28:36 EDT
[axet@mini rc3.d]$ sudo hp-setup 

HP Linux Imaging and Printing System (ver. 2.8.12)
Printer/Fax Setup Utility ver. 8.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

-Checking for network connection...
Downloading configuration file from: http://hplip.sf.net/plugin.conf
Checking for network connection...
Downloading plug-in from: http://www.linuxprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-2.8.12-plugin.run
Verifying archive integrity... All good.
Uncompressing HPLIP 2.8.12 Plugin Self Extracting Archive................................

HP Linux Imaging and Printing System (ver. 2.8.12)
Plugin Installer ver. 2.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 2.8.12)
Plugin Installer ver. 2.0

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Traceback (most recent call last):
  File "./plugin_install.py", line 334, in <module>
    installed_version = '.'.join(sys_cfg.hplip.version.split('.')[:3])
NameError: name 'sys_cfg' is not defined
Comment 1 Bug Zapper 2009-06-09 11:35:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tim Waugh 2009-07-01 11:17:30 EDT
This doesn't seem to be reported against the correct Fedora version.  Guessing you meant Fedora 10.

However, this seems to be a bug in the downloaded (proprietary) plug-in.  Nothing we can do to fix that.
Comment 3 Alexey Kuznetsov 2009-07-01 11:23:11 EDT
i guess download path hardcoded in source. and fedora 11 package should be upgraded to point last version of hp plugin.

if it not hardcoded then ok, close bug.
Comment 4 Tim Waugh 2009-07-01 11:37:18 EDT
> [axet@mini rc3.d]$ sudo hp-setup 
> 
> HP Linux Imaging and Printing System (ver. 2.8.12)

You are running hplip-2.8.12.  Fedora 11 comes with 3.9.2.

Note You need to log in before you can comment on or make changes to this bug.