Bug 500073 - Garmin Sync Fails With USBError: Device or resource busy
Garmin Sync Fails With USBError: Device or resource busy
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: garmin-sync (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 13:33 EDT by Devan Goodwin
Modified: 2009-05-11 11:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 11:30:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-05-10 13:33:26 EDT
Description of problem:

Attempting to run garmin-sync in rawhide fails with a USBError.
Version-Release number of selected component (if applicable):

garmin-sync-0.3-3.fc11.noarch

How reproducible:

Can't get rid of it.

Steps to Reproduce:
1. Plug in Garmin device. (Forerunner 305 in my case)
2. Run garmin-sync as root or via sudo.
  
Actual results:

(dev@kramer ~) $ sudo garmin-sync
Traceback (most recent call last):
  File "/usr/bin/garmin-sync", line 26, in <module>
    exit_value = garmin_sync.run()
  File "/usr/share/garmin-sync/garminsync.py", line 387, in run
    link = garmin.USBLink()
  File "/usr/share/garmin-sync/garmin.py", line 2091, in __init__
    self.handle.claimInterface(0)
usb.USBError: could not claim interface 0: Device or resource busy
(dev@kramer ~) $ 

Input does not occur.

Additional info:

System was upgraded from Fedora 10 via Fedora 11 Beta DVD. garmin-sync was working prior to this.

(root@kramer ~) $ lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 003: ID 091e:0003 Garmin International GPSmap (various models)
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 045e:0024 Microsoft Corp. Trackball Explorer
Bus 005 Device 003: ID 046d:c044 Logitech, Inc. LX3 Optical Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 045e:000b Microsoft Corp. Natural Keyboard Elite
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Running with -d yeilds no additional output.
Comment 1 Jeremy Katz 2009-05-11 11:30:16 EDT
You'll have to blacklist the garmin_gps module.  We had turned it off, but then requests came in to turn it back on.  Unfortunately, it conflicts with any apps wanting to do the (better) approach of using libusb :(

See bug 471824
Comment 2 Devan Goodwin 2009-05-11 11:59:20 EDT
Works for me. Thanks.

Note You need to log in before you can comment on or make changes to this bug.