Bug 500094 - JBoss Communications Platform / Mobicents not available as an option in the Product Dropdown List
JBoss Communications Platform / Mobicents not available as an option in the P...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Tony Fu
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 20:48 EDT by Jared MORGAN
Modified: 2015-08-09 21:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 17:26:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared MORGAN 2009-05-10 20:48:30 EDT
Description of problem:

The option to search on JBoss Communication Platform (JBCP) issues is not  available in Bugzilla.  Users need to be able to search for and log documentation bugs under this category, because it is specified that they report documentation errors using this method.


Version-Release number of selected component (if applicable):

Not applicable

How reproducible:

Easily reproducible.  Try to select "JBoss Communications Platform" from the Product menu when searching for a bug, or attempting to create a bug.

Steps to Reproduce:

From the main Bugzilla page:

1.Click Search Existing Bug Reports
2.Click the Product Dropdown list.
3.Try and find JBCP
  
Actual results:

No JBoss Communications Platform item in the list.

Expected results:

A JBoss Communications Platform item in the list for users to search on, or select when raising a bug against JBCP user documentation.

Additional info:

Nil
Comment 1 David Lawrence 2009-05-11 12:08:29 EDT
Those particular products are not available in the Bugzilla system and issues are tracked in a different location. Please check https://jira.jboss.org to see if you see what you are looking for.

Dave
Comment 2 Jared MORGAN 2009-05-26 18:12:33 EDT
Hi Dave

Could this issue please be reopened?  After consulting with Paul Gampe, the Docs bug component for the JBoss Communications Platform (JBCP) must be included in Bugzilla, and not JIRA.

Paul Gampe doesn't want customers logging bugs in JIRA for this particular product.  

At this stage, the Documentation is the only thing that will be tracked in Bugzilla.

Please feel free to confirm with Paul Gampe regarding this issue.
Comment 3 David Lawrence 2009-05-26 23:23:32 EDT
I am going to need the following required information from someone in order to create the new product in Bugzilla:

Product Name 	 Name of the product
Product Description 	Short description of the product
Product Versions 	List of all versions of the product
Product Group Access 	If you want to restrict product access to some Bugzilla groups you will need to provide the group names (ie devel, qa, etc.) Otherwise you can simply describe which groups should have access to the product (ie team, public, etc.).
Product Milestones 	OPTIONAL: Milestones of the product/project
Is it a Redhat Product? 	Yes/No
Is it a Fedora Product? 	Yes/No
List of components 	For each component you need to provide the following:

   1.
      Component Name - The name of the component/package
   2.
      Component Description - Short description of the component
   3.
      Component Owner - The default assignee/owner for the component
   4.
      OPTIONAL: Component Qa Conact - The default qa contact for the component
   5.
      OPTIONAL: Component CC list - The list of people who would like to watch this component and see all of its bugs
Comment 4 Jared MORGAN 2009-05-31 18:03:45 EDT
I have sent an email to Ivelin Ivanov, asking him to confirm the information required.  I am awaiting a response from Ivelin with the details.
Comment 5 Benjamin Kahn 2009-06-17 11:50:39 EDT
Product Name: JBoss Communications Platform
 
Product Description:  The JBoss Communications Platform (JBCP) is the first, and only, Open Source VoIP Platform certified for JSLEE 1.0 and SIP Servlets 1.1 compliance. JBCP brings to telecommunications applications a robust component model and execution environment. It compliments J2EE to enable convergence of voice, video and data in next generation intelligent applications.

Product Versions:  1.2.0, 1.2.1 (these are the only Red Hat offerings so far?)

Product Group Access:  Red Hat only (since it is not released yet)

Product Milestones  (OPTIONAL): Release Candidate (RC)

Is it a Redhat Product?  Yes

Is it a Fedora Product?  No

List of components (one for each):  

For each of the components below, a new mailing list needs to be created to act as the component owner.  Another mailing list should be created for the QA contact.  The list information is not yet available.

JAIN SLEE Server

   1.  Component Name - JAIN SLEE Server
   2.  Component Description - A high-performance, scalable and fault tolerant
                               Service Level Execution Environment. 
   3.  Component Owner - <info_required>
   4.  OPTIONAL: Component Qa Conact - <info_required>
   5.  OPTIONAL: Component CC list - Eduardo, Vladimir, Bartosz 

SIP Servlets Server

   1.  Component Name - SIP Servlets Server
   2.  Component Description - An open platform on which to develop and deploy
                               portable and distributable SIP and Converged JEE 
                               services. 
   3.  Component Owner - <info_required>
   4.  OPTIONAL: Component Qa Conact - <info_required>
   5.  OPTIONAL: Component CC list - Jean D, Vladimir

SIP Presence Service

   1.  Component Name - SIP Presence Service
   2.  Component Description - Provides presence functionalities to SIP-based
                               networks using standards developed by the internet
                               Engineering Task Force (IETF), the Open Mobile 
                               Alliance (OMA), the 3rd Generation Partnership
                               Project (3GPP) and the European telecommunications 
                               Standards Institute (ETSI). 
   3.  Component Owner - <info_required>
   4.  OPTIONAL: Component Qa Conact - <info_required>
   5.  OPTIONAL: Component CC list - Eduardo

Media Server

   1.  Component Name - Media Server
   2.  Component Description - An open source Media Server that delivers
                               competitive, complete, best-of-breed media 
                               gateway functionality.  
   3.  Component Owner - <info_required>
   4.  OPTIONAL: Component Qa Conact - <info_required>
   5.  OPTIONAL: Component CC list - Amit, Oleg

Documentation

   1.  Component Name - Product Documentation
   2.  Component Description - Documentation supporting the 
                               JBoss Communications Platform.  
   3.  Component Owner - Jared Morgan 
   4.  OPTIONAL: Component Qa Conact - Not required
   5.  OPTIONAL: Component CC list - Ivelin Ivanov


Distribution 

   1. Component Name - distribution
   2. Component Description - for any new components not added yet 
                              or a bug not particular to any component
   3. Component Owner - <info_required>
   4. OPTIONAL: Component Qa Conact - <info_required>
   5.  OPTIONAL: Component CC list - None
Comment 6 David Lawrence 2009-06-17 16:33:54 EDT
Thanks Ben, we will get this added asap.

Tony, do you mind working on getting this added to the Bugzilla products?

If you do not have time, then send it back my way.

Thanks
Dave
Comment 7 Jared MORGAN 2009-06-17 19:53:58 EDT
Hi Ben and David.

My apologies, I thought I appended the new requirements for this, but it seems like I must have done something wrong and they didn't come through.

At this stage, I think that the only items that should be added are the docs components.  Apparently the JBCP product related issues are handled through the CSP at the moment.  However, any docs issues should be reported through the Bugzilla tracking system.

I've updated the category information, and appended it below.  I'm the lead JBCP docs person, so any notifications should go to me.  I've used the format of the other JBoss docs projects to formulate the descriptions.  It seems that there is a bugzilla entry for each User Guide in other projects, so I have used the same format below.

Let me know if you need any further information.

Cheers

Jared

Component List

Platform User Guide

1.  Component Name - JBCP Platform User Guide
2.  Component Description - Your guide to the JBoss Communications
     Platform.
3.  Component Owner - Jared Morgan

JAIN SLEE Server User Guide

1.  Component Name - JBoss JAIN SLEE Server User Guide
2.  Component Description - Your guide to configuring and using the JAIN
     SLEE Server.
3.  Component Owner - Jared Morgan

SIP Servlets Server User Guide

1.  Component Name - JBoss SIP Servlets Server User Guide
2.  Component Description - Your guide to configuring and using the SIP
     Servlets Server.
3.  Component Owner - Jared Morgan

SIP Presence Service User Guide

1.  Component Name - JBoss SIP Presence Service User Guide
2.  Component Description - Your guide to configuring and using the SIP
     Presence Service.
3.  Component Owner - Jared Morgan

Media Server User Guide

1.  Component Name - JBoss Media Server User Guide
2.  Component Description - Your guide to configuring and using the SIP
     Presence Service.
3.  Component Owner - Jared Morgan
Comment 8 Tony Fu 2009-07-07 00:34:51 EDT
Hi Jared,

I have added these components to Bugzilla, according to your information.  

'cause you are using a non-redhat email account as Bugzilla login and JBoss Communications Platform product is restricted to Red Hat internal user only, you may have problem to access these components.  In order to fix this issue, you need to use your Red Hat email account to create a Bugzilla login.

If there are any other problems, please free feel to let me know.


Regards,
Tony
Comment 9 Jared MORGAN 2009-07-07 01:40:00 EDT
Hi Tony

Thanks for adding the information to the system.

I've changed my email address to my redhat email as recommended, but I still can't seem to see the options as selectable items in the categories.

Do I have to totally recreate my account for the categories to become visible to me?

Cheers

Jared
Comment 10 David Lawrence 2009-07-08 17:26:11 EDT
(In reply to comment #9)
> Hi Tony
> 
> Thanks for adding the information to the system.
> 
> I've changed my email address to my redhat email as recommended, but I still
> can't seem to see the options as selectable items in the categories.
> 
> Do I have to totally recreate my account for the categories to become visible
> to me?
> 
> Cheers
> 
> Jared  

I have updated your permissions so you should now see the new product/components properly.

Dave

Note You need to log in before you can comment on or make changes to this bug.