Bug 500129 - X restarts w/o apparent reason
X restarts w/o apparent reason
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 06:45 EDT by Dominik Sandjaja
Modified: 2009-10-15 16:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-15 16:23:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (557 bytes, text/plain)
2009-05-11 06:45 EDT, Dominik Sandjaja
no flags Details
Xorg.log (56.27 KB, text/plain)
2009-05-11 06:47 EDT, Dominik Sandjaja
no flags Details

  None (edit)
Description Dominik Sandjaja 2009-05-11 06:45:42 EDT
Created attachment 343422 [details]
xorg.conf

My X sometimes just crashes and restarts without any specific reason. Attached are the xorg.conf and the Xorg.log with the crash. I have no idea on what keywords to use on the search.

It is a Fedora 10 with some updates from testing.

Smolt:
http://www.smolts.org/client/show/pub_62b790b9-e780-4903-b210-06d06adee62a

Installed packages:
[root@illuminati ~]# rpm -qa | grep xorg
xorg-x11-fonts-ISO8859-1-100dpi-7.2-6.fc9.noarch
xorg-x11-server-common-1.5.3-15.fc10.i386
xorg-x11-util-macros-1.1.6-2.fc10.i386
xorg-x11-utils-7.4-3.fc10.i386
xorg-x11-drv-keyboard-1.3.2-1.fc10.i386
xorg-x11-server-Xdmx-1.5.3-15.fc10.i386
xorg-x11-xfs-1.0.5-3.1.fc10.i386
xorg-x11-drv-fbdev-0.3.1-7.fc9.i386
xorg-x11-drv-mouse-1.3.0-2.fc9.i386
xorg-x11-fonts-100dpi-7.2-6.fc9.noarch
xorg-x11-drv-synaptics-0.15.2-4.fc10.i386
xorg-x11-proto-devel-7.4-5.fc10.noarch
xorg-x11-server-Xvfb-1.5.3-15.fc10.i386
xorg-x11-drv-v4l-0.2.0-1.fc9.i386
xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch
xorg-x11-server-Xorg-1.5.3-15.fc10.i386
xorg-x11-filesystem-7.3-2.fc10.noarch
xorg-x11-server-utils-7.4-3.fc10.i386
xorg-x11-xauth-1.0.2-5.fc10.i386
xorg-x11-xinit-1.0.9-4.fc10.i386
xorg-x11-fonts-misc-7.2-6.fc9.noarch
xorg-x11-drv-void-1.1.1-9.fc9.i386
xorg-x11-drv-evdev-2.1.3-1.fc10.i386
xorg-x11-xdm-1.1.6-7.fc10.i386
xorg-x11-xkb-utils-7.2-7.fc10.i386
xorg-x11-font-utils-7.2-6.fc10.i386
xorg-x11-drv-ati-6.10.0-2.fc10.i386
xorg-x11-server-Xephyr-1.5.3-15.fc10.i386
xorg-x11-drv-vesa-2.2.0-3.fc10.i386
xorg-x11-fonts-75dpi-7.2-6.fc9.noarch
xorg-x11-fonts-Type1-7.2-6.fc9.noarch
xorg-x11-drv-dummy-0.3.0-1.fc9.i386
xorg-x11-apps-7.3-5.fc10.i386
xorg-x11-server-Xnest-1.5.3-15.fc10.i386
Comment 1 Dominik Sandjaja 2009-05-11 06:47:55 EDT
Created attachment 343424 [details]
Xorg.log
Comment 2 Dominik Sandjaja 2009-05-11 08:01:30 EDT
I now found out that the crash is reproducible: It always occurs when I start Filezilla. Maybe it is related to wxWidgets?

So, these are the packages on my system:

filezilla-3.1.6-1.fc10.1.i386
wxPython-2.8.9.1-1.fc10.i386
wxBase-2.8.9-1.fc10.i386
wxGTK-gl-2.8.9-1.fc10.i386
wxGlade-0.6.3-2.fc10.noarch
wxGTK-2.8.9-1.fc10.i386
Comment 3 Dominik Sandjaja 2009-05-12 03:02:46 EDT
OK, that is strange:
Removing ~/.filezilla makes the crashes stop ...

Well, although this is solved now, it shouldn't happen.
Comment 4 Matěj Cepl 2009-05-12 04:43:57 EDT
Yes, it shouldn't.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812be9b]
1: /usr/bin/Xorg(xf86SigHandler+0x51) [0x80bcca1]
2: [0x208400]
3: /usr/bin/Xorg(dixLookupPrivate+0x27) [0x806c077]
4: /usr/bin/Xorg(CreatePicture+0x135) [0x8159cd5]
5: /usr/bin/Xorg [0x81608e9]
6: /usr/bin/Xorg [0x815af05]
7: /usr/bin/Xorg(Dispatch+0x34f) [0x8085ebf]
8: /usr/bin/Xorg(main+0x47d) [0x806b73d]
9: /lib/libc.so.6(__libc_start_main+0xe5) [0x47a6e5]
10: /usr/bin/Xorg [0x806ab21]

Fatal server error:
Caught signal 11.  Server aborting
Comment 5 seventhguardian 2009-10-14 18:15:16 EDT
You could try installing Xorg's debug symbols

$ debuginfo-install xorg-x11-server-Xorg

 and running a gdb session. That would help to figure out where it crashes.
Comment 6 Dominik Sandjaja 2009-10-15 16:23:49 EDT
Well, in the meantime I installed F11 and cannot reproduce the problem anymore. IIRC the problem was something along the wx* packages, but my memory isn't as good as it used to be :-) Anyway, this report can be closed.

Note You need to log in before you can comment on or make changes to this bug.