Bug 500173 - Unable to run migrate-system-profile
Unable to run migrate-system-profile
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Preethi Thomas
:
Depends On:
Blocks: 456998 486216
  Show dependency treegraph
 
Reported: 2009-05-11 09:55 EDT by Preethi Thomas
Modified: 2009-09-10 14:16 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:16:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-05-11 09:55:45 EDT
Description of problem:
migrate-system-profile is not available in the latest build
Version-Release number of selected component (if applicable):


How reproducible:
Satellite-5.3.0-RHEL5-re20090507.1-i386-embedded-oracle.iso

Steps to Reproduce:
1.from the command line of the satellite server
2. run  migrate-system-profile
3.
  
Actual results:
[root@rlx-3-24 ~]# migrate-system-profile --help
Unable to find migrate server tool.
Error: cannot import name migrateSystemProfile


Expected results:


Additional info:
Comment 1 Brad Buckingham 2009-05-11 10:01:37 EDT
I'll take this one.  The script was moved from spacewalk-backend-utils to spacewalk-utils pkg.  This was done so that a user could install it on a system other than the satellite.  Unfortunately, looks like although the scripts/files were moved, the main migrate-system-profile was not updated to import the migrateSystemProfile from the correct place.
Comment 2 Brad Buckingham 2009-05-11 10:48:10 EDT
master git commit: c1e718c67e04ccb2c40bc178778dddd6b0a5695f
vader git commit: 717a7d3e7d89764dec2a829407b017e1afe594cd
Comment 3 Brad Buckingham 2009-05-20 09:21:07 EDT
Mass move to ON_QA.
Comment 4 Preethi Thomas 2009-05-27 17:25:52 EDT
verified.
Satellite-5.3.0-RHEL4-re20090521.1-i386-embedded-oracle.iso
successfully  ran  migrate-system-profile as satellite admin as well as org admin
Comment 5 Preethi Thomas 2009-09-02 10:20:55 EDT
Release pending
migrate system profile works in stage.
Comment 6 Brandon Perkins 2009-09-10 14:16:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.