Bug 500190 - GFS2 not deleting work files after IOZONE runs.
GFS2 not deleting work files after IOZONE runs.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Steve Whitehouse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 11:18 EDT by Ben Marzinski
Modified: 2009-05-27 23:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 02:27:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Marzinski 2009-05-11 11:18:27 EDT
Description of problem:

Running the test
# ./iozone -az -f ./work -n 4096m -g 4096m -y 8k -q 1m >&outcache1.log

from a gfs2 directory in a cluster causes the ./work file not to be deleted. Iozone deletes this file at the end of its run.

Version-Release number of selected component (if applicable):
kernel-2.6.18-140.gfs2abhi.004

How reproducible:
Always, but the current test takes hours.


Steps to Reproduce:
1. Start up a cluster (I'm using three nodes), and create a gfs2 file system on it.
2. In the gfs2 directory run
# ./iozone -az -f ./work -n 4096m -g 4096m -y 8k -q 1m >&outcache1.log
  
Actual results:
the ./work file is not deleted

Expected results:
the ./work file is deleted

Additional info:
Comment 1 Ben Marzinski 2009-05-12 02:27:16 EDT
I suppose I should have tried this test on ext3 earlier.  It does the same thing there.  The reason why I couldn't see the delete happening in gfs2 is apparently because it doesn't actually happen.  For some reason iozone doesn't delete files that are 2GB or larger.

Note You need to log in before you can comment on or make changes to this bug.