Bug 500313 - With DHCP reset timeout set to 30 seconds - openais segfaults
With DHCP reset timeout set to 30 seconds - openais segfaults
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: corosync (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jan Friesse
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 04:42 EDT by Steven Dake
Modified: 2016-04-27 01:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 224518
Environment:
Last Closed: 2009-06-03 10:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2009-05-12 04:42:28 EDT
+++ This bug was initially created as a clone of Bug #224518 +++

Description of problem:
Segfault occurs when DHCP reset timeout set to 30 seconds.

Version-Release number of selected component (if applicable):
latest.

How reproducible:
takes a few hours to reproduce.

Steps to Reproduce:
1.Set DHCP timeout to 30 seconds for machines in a RHCS setup.
2.Run revolver.
3.
  
Actual results:
Segfault

Expected results:
No segfault

Additional info:
This use case is not supported - however - the software should still not segfault.
Comment 1 Steven Dake 2009-05-12 04:43:37 EDT
Honzaf,
This is very low priority, but if you run out of better things to do, try to reproduce this bug and let us know if it still exists or close as not a defect in corosync.
Comment 2 Jan Friesse 2009-06-01 11:13:24 EDT
Steve,
I'm trying to reproduce this bug. It's fully dynamic DHCP (pool, but leases are still same), and running testcpg in while cycle (send one message). Whole thing is running 6 hours now, and I was not able to get error.

On a beginning, I was able to get "bus error" and "aborted" messages, with shutting down and up dhclient, but never get segfault.

Is my testing correct?

If yes, is 6 hours enough, to close bug?
Comment 3 Steven Dake 2009-06-02 13:53:13 EDT
Did you have lease period set to 30 seconds?  If so, then go ahead close fixed currentrelease.

Regards
-steve
Comment 4 Jan Friesse 2009-06-03 10:58:30 EDT
I was unable to reproduce this bug with corosync trunk (r2203) so I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.