Bug 500376 - Segmentation fault when the number of vcpu is larger than MAX_VCPUS
Segmentation fault when the number of vcpu is larger than MAX_VCPUS
Status: CLOSED DUPLICATE of bug 587227
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Burke
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 09:50 EDT by lihuang
Modified: 2013-01-09 16:37 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 12:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lihuang 2009-05-12 09:50:57 EDT
Description of problem:
When booting a vm with 32 vcpus. qemu-kvm exited with SIGSEGV.



Version-Release number of selected component (if applicable):
kvm-83-39.el5ovirt

How reproducible:
every time 

Steps to Reproduce:
1.boot vm with 32 vcpu
2.
3.
  
Actual results:
[root@dhcp-66-70-55 exports]# gdb qemu-kvm 
GNU gdb Fedora (6.8-27.el5)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(gdb) r  -hda /dev/null -smp 32 -m 4096 
Starting program: /usr/bin/qemu-kvm -hda /dev/null -smp 32 -m 4096
[Thread debugging using libthread_db enabled]
[New Thread 0x2b33f4a0edd0 (LWP 1559)]
[New Thread 0x41762940 (LWP 1562)]
[New Thread 0x40d0a940 (LWP 1563)]
[New Thread 0x426e5940 (LWP 1564)]
[New Thread 0x430e6940 (LWP 1565)]
[New Thread 0x43ae7940 (LWP 1566)]
[New Thread 0x444e8940 (LWP 1567)]
[New Thread 0x44ee9940 (LWP 1568)]
[New Thread 0x458ea940 (LWP 1569)]
[New Thread 0x462eb940 (LWP 1570)]
[New Thread 0x46cec940 (LWP 1571)]
[New Thread 0x476ed940 (LWP 1572)]
[New Thread 0x480ee940 (LWP 1573)]
[New Thread 0x48aef940 (LWP 1574)]
[New Thread 0x494f0940 (LWP 1575)]
[New Thread 0x49ef1940 (LWP 1576)]
[New Thread 0x4a8f2940 (LWP 1577)]
[New Thread 0x4b2f3940 (LWP 1578)]
[New Thread 0x4bcf4940 (LWP 1579)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x4c6f5940 (LWP 1580)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x4d0f6940 (LWP 1581)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x4daf7940 (LWP 1582)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x4e4f8940 (LWP 1583)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x4eef9940 (LWP 1584)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x4f8fa940 (LWP 1585)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x502fb940 (LWP 1586)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x50cfc940 (LWP 1587)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x516fd940 (LWP 1588)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x520fe940 (LWP 1589)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x52aff940 (LWP 1590)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x53500940 (LWP 1591)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x53f01940 (LWP 1592)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x54902940 (LWP 1593)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x55303940 (LWP 1594)]
kvm_create_vcpu: Invalid argument
kvm_set_lapic: Bad file descriptor
[New Thread 0x55d04940 (LWP 1595)]
kvm_set_msrs FAILED: Bad file descriptor

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x55303940 (LWP 1594)]
0x000000000053edc2 in kvm_get_interrupt_flag (kvm=0x971d760, vcpu=31)
    at libkvm.c:875
875             return run->if_flag;
(gdb) bt
#0  0x000000000053edc2 in kvm_get_interrupt_flag (kvm=0x971d760, vcpu=31)
    at libkvm.c:875
#1  0x0000000000536cf4 in kvm_arch_post_kvm_run (opaque=<value optimized out>, 
    env=0x9965160)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm-x86.c:577
#2  0x000000000053ed64 in post_kvm_run (kvm=0x971d760, env=0x9965160)
    at libkvm.c:863
#3  0x000000000053eed9 in kvm_run (kvm=0x971d760, vcpu=31, env=0x9965160)
    at libkvm.c:904
#4  0x00000000005143c9 in kvm_cpu_exec (env=0x971d760)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm.c:210
#5  0x0000000000514660 in ap_main_loop (_env=<value optimized out>)
    at /usr/src/debug/kvm-83-maint-snapshot-20090205/qemu/qemu-kvm.c:413
#6  0x0000003717406367 in start_thread () from /lib64/libpthread.so.0
#7  0x00000037168d30ad in clone () from /lib64/libc.so.6
(gdb) 


Expected results:
qemu-kvm exit with proper error 

Additional info:
Comment 1 Dor Laor 2009-05-13 17:12:04 EDT
It is a bug but has zero priority.
Comment 2 RHEL Product and Program Management 2009-06-22 14:47:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Eduardo Habkost 2010-01-20 06:53:03 EST
On RHEL-6, the KVM userspace package is named "qemu-kvm". Moving bug to the right component.
Comment 4 lihuang 2010-04-30 12:11:32 EDT

*** This bug has been marked as a duplicate of bug 587227 ***

Note You need to log in before you can comment on or make changes to this bug.