Bug 500401 - blkiomon: endianess problem
blkiomon: endianess problem
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: blktrace (Show other bugs)
5.3
ia64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 11:09 EDT by Milos Malik
Modified: 2009-05-14 11:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 11:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (43.25 KB, text/plain)
2009-05-12 11:09 EDT, Milos Malik
no flags Details

  None (edit)
Description Milos Malik 2009-05-12 11:09:15 EDT
Created attachment 343592 [details]
strace output

Description of problem:
It seems that blkiomon gets into problems when consuming data from blktrace on ia64 machine.

Version-Release number of selected component (if applicable):
RHEL5.4-Server-20090512.nightly
blktrace-1.0.0-5.el5
kernel-2.6.18-141.el5

How reproducible:
always

Steps to Reproduce:
# mount -t debugfs debugfs /sys/kernel/debug/
# blktrace -w 60 -d /dev/cciss/c0d0 | blkiomon -I 10 -h - 
blkiomon: endianess problem
# strace -o output.txt blktrace -w 60 -d /dev/cciss/c0d0 | blkiomon -I 10 -h -
blkiomon: endianess problem
# time blktrace -w 60 -d /dev/cciss/c0d0 | blkiomon -I 10 -h -
blkiomon: endianess problem

real	1m0.164s
user	0m0.003s
sys	0m0.915s

# umount /sys/kernel/debug/
  
Actual results:


Expected results:
Comment 2 Eric Sandeen 2009-05-13 18:22:21 EDT
Milos, did you say this was NOTABUG due to missing "-o -" for blktrace?

# blktrace -w 5 -d /dev/sda | blkiomon -I 10 -h -
blkiomon: endianess problem

# blktrace -w 5 -d /dev/sda -o - | blkiomon -I 10 -h -
# 

if you agree let's close it :)

Thanks,
-Eric
Comment 3 Milos Malik 2009-05-14 02:56:34 EDT
I agree. Could you close it please?
Comment 4 Eric Sandeen 2009-05-14 11:15:22 EDT
need to pipe that output somewhere for blkiomon to get what it expects :)

Thanks,
-Eric

Note You need to log in before you can comment on or make changes to this bug.