Bug 500409 - system-config-kickstart traceback in save file dialog
system-config-kickstart traceback in save file dialog
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 11:32 EDT by Roman Rakus
Modified: 2014-01-12 19:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 13:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback (586 bytes, text/plain)
2009-05-12 11:33 EDT, Roman Rakus
no flags Details
Patch (2.10 KB, patch)
2009-05-12 11:35 EDT, Roman Rakus
no flags Details | Diff

  None (edit)
Description Roman Rakus 2009-05-12 11:32:23 EDT
Description of problem:
system-config-kickstart traceback in save file dialog if file name is empty

Version-Release number of selected component (if applicable):
system-config-kickstart-2.7.22-1

How reproducible:


Steps to Reproduce:
1. File -> Save File (CTRL + S)
2. Set name to empty string
3. Hit enter (or click on Save)
  
Actual results:
traceback 

Expected results:
Do nothing

Additional info:
I will attach traceback and patch.
Comment 1 Roman Rakus 2009-05-12 11:33:23 EDT
Created attachment 343597 [details]
Traceback
Comment 2 Roman Rakus 2009-05-12 11:35:12 EDT
Created attachment 343598 [details]
Patch

Simple check...
Comment 3 Chris Lumens 2009-05-20 13:12:42 EDT
Yep, looks pretty simple.  I'm going to change it to just check for not self.dialog.filePath and return in that case, though, since it involves less indenting.  Thanks for the patch.

Note You need to log in before you can comment on or make changes to this bug.