Bug 500429 - shared public child channels are displayed twice under activationkey->child channels
shared public child channels are displayed twice under activationkey->child ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Preethi Thomas
:
: 502882 (view as bug list)
Depends On:
Blocks: 456998 486216
  Show dependency treegraph
 
Reported: 2009-05-12 12:45 EDT by Preethi Thomas
Modified: 2011-07-15 20:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:16:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ise on activation key (3.31 KB, text/plain)
2009-05-12 12:45 EDT, Preethi Thomas
no flags Details
child-channel in activation key (64.19 KB, image/png)
2009-05-21 14:40 EDT, Preethi Thomas
no flags Details

  None (edit)
Description Preethi Thomas 2009-05-12 12:45:40 EDT
Created attachment 343625 [details]
ise on activation key

Description of problem:
shared child channels are displayed twice under activationkey->child channels

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090507.1-i386-embedded-oracle.iso
How reproducible:


Steps to Reproduce:
1.create 2 orgs orgA & orgB
2.establish a trust between orgA &orgB
3.create a public channel in orgA 
4. create another public channel as the child of the above channel.
5. create an activation key with provisioning checked
6. navigate to the child channel tab for the activation key
7. see that child channel is displayed twice
8. select the child channel and click on update key.


  
Actual results:
shared child channels are displayed twice.
selecting the child channel results in ISE

Expected results:


Additional info:
The following exception occurred while executing this request:
 POST /network/account/activation_keys/child_channels.pxt HTTP/1.1 (from browser)
 /network/account/activation_keys/child_channels.pxt (from Apache)

Date:
  Tue May 12 12:10:28 2009

Headers:
  Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Accept-Encoding: gzip,deflate
  Accept-Language: en-us,en;q=0.5
  Connection: keep-alive
  Content-Length: 143
  Content-Type: application/x-www-form-urlencoded
  Cookie: rh_omni_tc=70160000000H4AoAAK; s_vi=[CS]v1|49ADE3A00000275D-A3A0999000007BF[CE]; __qca=49acb2eb-314b0-7ea25-f74b9; pxt-session-cookie=1540xf704bc1e5b68e16ba63b866009178397; pxt-session-cookie=1540xf704bc1e5b68e16ba63b866009178397
  Host: rlx-0-10.rhndev.redhat.com
  Keep-Alive: 300
  Referer: https://rlx-0-10.rhndev.redhat.com/network/account/activation_keys/child_channels.pxt?tid=41
  User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008120908 Red Hat/3.0.5-1.el5_2 Firefox/3.0.5

Form variables:
  Update Key => Update Key
  pxt:trap => rhn:edit_token_channels_cb
  tid => 41
  token_child_channels => 125
  token_child_channels => 125
  token_child_channels => 125

User Information:
  User pt-org2 (id 22, org_id 3)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  RHN::Exception: DBD::Oracle::st execute failed: ORA-00001: unique constraint (RHNSAT.RHN_REG_TOK_CHN_UQ) violated (DBD ERROR: OCIStmtExecute) [for Statement "INSERT INTO rhnRegTokenChannels
            (token_id, channel_id)
SELECT DISTINCT :tid, :cid
Comment 1 Preethi Thomas 2009-05-12 12:50:05 EDT
missed a step in the test plan

5. create an activation with the public custom channel from step 3
Comment 2 Shannon Hughes 2009-05-13 13:23:08 EDT
this looks fixed in spacewalk code and was probably fixed from 492588.  lets do a retest in qa. 

<Preethi> shughes, looks like thats fixed on your satellite
<shughes> Preethi, k...thanks for cross checking
<Preethi> shughes, np
<shughes> i modified the query for that page late last week...i think that fixed it
Comment 3 Shannon Hughes 2009-05-20 12:02:50 EDT
mass move to onqa
Comment 4 Preethi Thomas 2009-05-21 14:39:13 EDT
fails in the latest iso
Satellite-5.3.0-RHEL5-re20090520.0-i386-embedded-oracle.iso
attached screen shot
Comment 5 Preethi Thomas 2009-05-21 14:40:43 EDT
Created attachment 345010 [details]
child-channel in activation key
Comment 6 Shannon Hughes 2009-05-26 13:58:22 EDT
took out join against rhnSharedChannelView to prevent dups.
Comment 7 wes hayutin 2009-05-27 13:13:48 EDT
*** Bug 502882 has been marked as a duplicate of this bug. ***
Comment 8 Shannon Hughes 2009-05-29 13:31:35 EDT
mass move to onqa
Comment 9 Preethi Thomas 2009-06-01 11:58:52 EDT
verified.
Satellite-5.3.0-RHEL5-re20090529.0-i386-embedded-oracle

shared child channels are only displayed once under activation key
Comment 10 Tomas Lestach 2009-09-07 06:01:10 EDT
Confirming Comment#9

Stage validated -> RELEASE_PENDING
Comment 11 Brandon Perkins 2009-09-10 14:16:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.