Bug 500449 - xorg ati driver has possible link problem in ati_r500
xorg ati driver has possible link problem in ati_r500
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.3
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 14:22 EDT by Peter Lannigan
Modified: 2014-06-17 12:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lannigan 2009-05-12 14:22:55 EDT
Description of problem:

Running "Xorg -configure" produces the following error.

(EE) LoadModule: Module ati_r500 does not have a ati_r500ModuleData data object.
(EE) Failed to load module "ati_r500" (invalid module, 0)

Hardware is a Dell Optiplex 755 with the following video card
01:00.0 VGA compatible controller: ATI Technologies Inc RV610 [Radeon HD 2400 XT]

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati.x86_64   6.6.3-3.22.el5

How reproducible:

Very

Steps to Reproduce:
1. move /etc/X11/xorg.conf out of the way
2. run 'Xorg -configure'
3. check logs
  
Actual results:


Expected results:


Additional info:

To get around the problem I removed the following file and soft-link from /usr/lib64/xorg/modules/drivers:  ati_r500_drv.so ati_tp_drv.so.  Once those were removed the 'Xorg -configure' ran fine.
Comment 1 Matěj Cepl 2009-05-16 17:58:46 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Adam Jackson 2009-08-03 10:32:36 EDT
This doesn't need X log, it's a straightforward build problem.

Adding to 5.5 radar.
Comment 3 RHEL Product and Program Management 2009-11-06 13:47:38 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 RHEL Product and Program Management 2014-03-07 08:56:58 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-02 09:23:55 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 6 Peter Lannigan 2014-06-17 12:17:26 EDT
Closed.

Note You need to log in before you can comment on or make changes to this bug.