Bug 500455 - Sluggish loading of the "new bug" page
Sluggish loading of the "new bug" page
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-12 15:01 EDT by Dimi Paun
Modified: 2013-06-23 22:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 23:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimi Paun 2009-05-12 15:01:09 EDT
Description of problem:
It takes ~40s+ to open the new bug report page. That's ~40s too long.
This should be sub-second for a simple page like this.
Comment 1 Emmanuel Seyman 2009-05-12 17:51:31 EDT
Changing products.
There's got to be an easier to not make a living.
Comment 2 David Lawrence 2009-05-12 18:08:11 EDT
This is probably referring to the Fedora bug entry page. The page is large mainly because it is rendering a select form field for 6000+ components. Bugzilla was not originally designed for as many components as we are trying to use. We are working on how to best solve this solution.
Comment 3 Dimi Paun 2009-05-13 01:06:53 EDT
Well, particularly when you come to the page with a preselected component, there's no reason to load all 6000 other components -- just make that field immutable, or load the components on demand via JS _if_ the user wants to change it.
Comment 4 Zack Cerza 2009-05-13 15:00:07 EDT
Would a text area with autocompletion, coupled with a "show me a list" link be feasible?
Comment 5 Dimi Paun 2009-05-13 15:23:08 EDT
Of course, why not?
Comment 6 David Lawrence 2009-05-13 15:32:13 EDT
(In reply to comment #4)
> Would a text area with autocompletion, coupled with a "show me a list" link be
> feasible?  

This is somewhat related to bug 461049 already in progress.

Dave
Comment 7 David Lawrence 2010-01-15 11:55:52 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this bug will need to be re-verified against the new release. With
the updated code this bug may no longer be relevant or may have been fixed in
the new code. Updating bug version to 3.4.
Comment 8 David Lawrence 2010-08-25 17:41:50 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 9 Dimi Paun 2010-08-25 23:48:33 EDT
Yes, this problem seems to have been fixed, thanks!

Note You need to log in before you can comment on or make changes to this bug.