Bug 500499 - Task engine status times not displayed properly
Task engine status times not displayed properly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Sayli Karmarkar
:
Depends On: 502959
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-05-12 18:15 EDT by Justin Sherrill
Modified: 2009-09-10 16:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2009-05-12 18:15:29 EDT
Log in as a satellite admin 

go to "admin" -> task engine status:

/internal/satellite/task_engine/index.pxt

Current DB Time: 	{current_db_time}
- Last Execution Times - 	 
Main Task Engine: 	{last_task_completed} 	 
Session Cleanup: 	{session_cleanup} 	 
Errata Notification Queue: 	{errata_queue} 	 
Errata Notification Mail: 	{errata_engine} 	 
Daily Summary Queue: 	{summary_populator} 	 
Daily Summary Mail: 	{errata_engine} 	 
Clean Current Alerts: 	{clean_current_alerts} 	 
Synch Probe State: 	{synch_probe_state} 	 


as you can see these aren't actual times.
Comment 1 Clifford Perry 2009-05-14 10:39:54 EDT
Agree, I see it also. 

Needs investigation/fixed.
Comment 2 Justin Sherrill 2009-05-14 18:21:45 EDT
converted to java as all the perl code had been ripped out last august :}



21b9d58
Comment 3 Sayli Karmarkar 2009-06-01 23:32:56 EDT
Justin,

I can see times as:

Current DB Time:  	 6/2/09 4:07:16 PM PHOT
Last Execution Times
Last Completed Action: 	6/2/09 4:07:00 PM PHOT
Session Cleanup: 	6/2/09 4:00:01 PM PHOT
Errata Notification Queue: 	6/2/09 4:07:00 PM PHOT
Errata Notification Mail: 	6/2/09 4:00:01 PM PHOT
Daily Summary Queue: 	6/2/09 4:00:02 PM PHOT
Daily Summary Mail: 	6/1/09 10:00:00 PM PHOT
Clean Current Alerts: 	6/1/09 9:35:00 PM PHOT
Sync Probe State: 	6/2/09 4:07:00 PM PHOT 

Whats PHOT in this case? Is this expected? 

~SayliK
Comment 4 Sayli Karmarkar 2009-06-02 14:55:26 EDT
Looks like somehow timezone setting in locale preferences got changed. Looks good now:

The following is a status report for the various tasks run by the RHN Satellite task engine:
Current DB Time: 	6/2/09 2:48:41 PM EDT
Last Execution Times
Last Completed Action: 	6/2/09 2:48:00 PM EDT
Session Cleanup: 	6/2/09 2:45:00 PM EDT
Errata Notification Queue: 	6/2/09 2:48:00 PM EDT
Errata Notification Mail: 	6/2/09 2:30:00 PM EDT
Daily Summary Queue: 	6/1/09 11:00:02 PM EDT
Daily Summary Mail: 	6/2/09 5:00:02 AM EDT
Clean Current Alerts: 	6/2/09 4:35:00 AM EDT
Sync Probe State: 	6/2/09 2:48:00 PM EDT 

Moving to verified. 

~SayliK
Comment 5 Miroslav Suchý 2009-08-17 11:35:47 EDT
verified in stage
Comment 6 Brandon Perkins 2009-09-10 16:36:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.