Bug 500550 - check-debuginfo is empty
check-debuginfo is empty
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: check (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 05:03 EDT by Alexander Todorov
Modified: 2013-04-12 16:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 10:14:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-05-13 05:03:03 EDT
Description of problem:
check-debuginfo package is empty.

Version-Release number of selected component (if applicable):
check-debuginfo-0.9.3-5.fc6.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -qpl check-debuginfo-0.9.3-5.fc6.i386.rpm
2.
3.
  
Actual results:
empty package

Expected results:
not sure, see additional info

Additional info:
The only file of interest in check-devel package (i.e. not source code or documentation) is /usr/lib/libcheck.a which is an ar archive containing ELF objects. I don't know how debugging information should be generated/used in this case.

$ file /usr/lib/libcheck.a
/usr/lib/libcheck.a: current ar archive

$ ar xv libcheck.a 
x - check.o
x - check_error.o
x - check_list.o
x - check_log.o
x - check_msg.o
x - check_pack.o
x - check_print.o
x - check_run.o
x - check_str.o

$ file check*
check-0.9.3-5.fc6.src.rpm: RPM v3 src i386 check-0.9.3-5.fc6
check_error.o:             ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
check_list.o:              ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
check_log.o:               ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
check_msg.o:               ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
check.o:                   ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
check_pack.o:              ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
check_print.o:             ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
check_run.o:               ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
check_str.o:               ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped
Comment 5 Adam Jackson 2012-04-18 10:14:08 EDT
If this were to be fixed, it'd just be to disable building the debuginfo subpackage.  But I don't think it ever will, since it's harmless.

Note You need to log in before you can comment on or make changes to this bug.