Bug 500554 - can not install 520 on RHEL5-U3 because of dependency issues
can not install 520 on RHEL5-U3 because of dependency issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
All Linux
low Severity low
: ---
: ---
Assigned To: Milan Zázrivec
Garik Khachikyan
:
Depends On:
Blocks: 456986 456999 463877
  Show dependency treegraph
 
Reported: 2009-05-13 05:36 EDT by Jan Hutař
Modified: 2015-01-04 16:56 EST (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 13:33:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn-installation.log (86.75 KB, text/plain)
2009-05-13 05:36 EDT, Jan Hutař
no flags Details
complete log of the installation 520 on RHEL52 (12.68 KB, application/x-gzip)
2009-06-02 04:50 EDT, Garik Khachikyan
no flags Details
satellite520_RHEL53 install log (147.45 KB, application/octet-stream)
2009-06-02 08:20 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Jan Hutař 2009-05-13 05:36:14 EDT
Created attachment 343732 [details]
rhn-installation.log

Description of problem:
I have installed new RHEL5-U3-Server and when I try to install Satellite, I'm getting dependency issues.


Version-Release number of selected component (if applicable):
Satellite-5.2.0-RHEL5-re20081028.3-x86_64-embedded-oracle.iso


How reproducible:
always


Steps to Reproduce:
1. # ./install.pl --answer-file=.../answers.txt --non-interactive --disconnected --run-updater


Actual results:
dep issues


Expected results:
no dep issues


Additional info:
# yum repolist
Loaded plugins: rhnplugin, security
repo id              repo name                                status  
rhel-x86_64-server-5 Red Hat Enterprise Linux (v. 5 for 64-bi enabled :   6,838
rhel-x86_64-server-5 MRG Grid v. 1 (for RHEL 5 Server 64-bit  enabled :      31
rhel-x86_64-server-5 MRG Grid Execute Node v. 1 (for RHEL 5 S enabled :      31
rhel-x86_64-server-5 MRG Management v. 1 (for RHEL 5 Server 6 enabled :       8
rhel-x86_64-server-5 MRG Messaging v. 1 (for RHEL 5 Server 64 enabled :      51
rhel-x86_64-server-5 MRG Messaging Base v. 1 (for RHEL 5 Serv enabled :      35
rhel-x86_64-server-5 MRG Realtime v. 1 (for RHEL 5 Server 64- enabled :      88
rhel-x86_64-server-c RHEL Clustering (v. 5 for 64-bit x86_64) enabled :     116
rhel-x86_64-server-c RHEL Cluster-Storage (v. 5 for 64-bit x8 enabled :     144
rhel-x86_64-server-f RHEL FasTrack (v. 5 for 64-bit x86_64)   enabled :      34
rhel-x86_64-server-h RHEL Hardware Certification (v. 5 for 64 enabled :      10
rhel-x86_64-server-p RHEL Optional Productivity Apps (v. 5 fo enabled :   1,063
rhel-x86_64-server-s RHEL Supplementary (v. 5 for 64-bit x86_ enabled :     465
rhel-x86_64-server-v RHEL Virtualization (v. 5 for 64-bit x86 enabled :     176
rhn-tools-rhel-x86_6 Red Hat Network Tools for RHEL Server (v enabled :     421
repolist: 9,511
# yum list --showduplicates perl-NOCpulse-Probe tsdb SatConfig-installer np-config SatConfig-general perl-NOCpulse-Debug NPalert MessageQueue ssl_bridge SputLite-server perl-NOCpulse-Probe SatConfig-general status_log_acceptor
Loaded plugins: rhnplugin, security
Error: No matching Packages to list
# rpm -q perl-NOCpulse-Probe tsdb SatConfig-installer np-config SatConfig-general perl-NOCpulse-Debug NPalert MessageQueue ssl_bridge SputLite-server perl-NOCpulse-Probe SatConfig-general status_log_acceptor
package perl-NOCpulse-Probe is not installed
package tsdb is not installed
package SatConfig-installer is not installed
package np-config is not installed
package SatConfig-general is not installed
package perl-NOCpulse-Debug is not installed
package NPalert is not installed
package MessageQueue is not installed
package ssl_bridge is not installed
package SputLite-server is not installed
package perl-NOCpulse-Probe is not installed
package SatConfig-general is not installed
package status_log_acceptor is not installed

I was not succesfull even with most of the repos ^^^ disabled:

# yum repolist
Loaded plugins: rhnplugin, security
repo id              repo name                                status  
rhel-x86_64-server-5 Red Hat Enterprise Linux (v. 5 for 64-bi enabled :   6,838
rhn-tools-rhel-x86_6 Red Hat Network Tools for RHEL Server (v enabled :     421
repolist: 8,997
Comment 1 Jan Hutař 2009-05-13 05:39:54 EDT
I'm getting similar dependency issues with fully updated RHEL5-U3.
Comment 2 Jan Hutař 2009-05-13 06:07:17 EDT
(system is registered against WebQA)
Comment 3 Brandon Perkins 2009-05-14 11:16:30 EDT
We believe this is due to the nocpulse-common package being added to the rhn-tools channel in WebQA:

nocpulse-common-2.1.8-1.el5sat.noarch  NOCpulse common
nocpulse-common-2.1.8-2.el5sat.noarch  NOCpulse common
nocpulse-common-2.1.8-3.el5sat.noarch  NOCpulse common

obviously we cannot break old installs.  Important parts from the attachment:

Package ConfigPusher-general is obsoleted by nocpulse-common, trying to install nocpulse-common-2.1.8-3.el5sat.noarch instead
Package np-config is obsoleted by nocpulse-common, trying to install nocpulse-common-2.1.8-3.el5sat.noarch instead
Package NPusers is obsoleted by nocpulse-common, trying to install nocpulse-common-2.1.8-3.el5sat.noarch instead
Package nslogs is obsoleted by nocpulse-common, trying to install nocpulse-common-2.1.8-3.el5sat.noarch instead
---> Package nocpulse-common.noarch 0:2.1.8-3.el5sat set to be updated
Comment 4 Clifford Perry 2009-05-14 11:18:14 EDT
Also, at bottom of attached log file:

Error: Missing Dependency: NPusers is needed by package perl-NOCpulse-Scheduler-1.58.4-8.el5.noarch (Satellite/perl-NOCpulse-Scheduler-1.58.4-8.el5.noarch.rpm)
Error: Missing Dependency: np-config is needed by package status_log_acceptor-0.12.5-8.el5.noarch (Satellite/status_log_acceptor-0.12.5-8.el5.noarch.rpm)
Comment 5 Milan Zázrivec 2009-05-15 05:52:08 EDT
The true fix for this problem is in fact to remove nocpulse-common
package from RHN-Tools composes so that it won't be propagated
into the hosted environment anymore.

nocpulse-common package was added to the RHN-Tools-5.3.0 composes
at some point (as an rhnmd requirement), but is no longer needed.

RT ticket to release-engineering@redhat.com asking to remove
the package from RHN-Tools comps:
https://engineering.redhat.com/rt3/Ticket/Display.html?id=41138
Comment 6 Milan Zázrivec 2009-05-15 11:30:39 EDT
Ticket mentioned above has been resolved by Daniel Mach.
Comment 7 Milan Zázrivec 2009-05-25 10:59:04 EDT
RT ticket to release-enginnering@redhat.com asking to remove
nocpulse-common package from rhn-tools channels in webqa
https://engineering.redhat.com/rt3/Ticket/Display.html?id=41768
has been resolved by Daniel Mach.
Comment 9 Garik Khachikyan 2009-06-02 04:50:46 EDT
Created attachment 346211 [details]
complete log of the installation 520 on RHEL52
Comment 10 Garik Khachikyan 2009-06-02 04:56:59 EDT
The installation of 520 on RHEL52 (on arch-s i386, x86_64) gave the same results. Please refer to the logs attached in the comment above.

Could you please provide more info if the issue is fixed, as it seems not... 
Thanks in advance.
Comment 11 Milan Zázrivec 2009-06-02 05:08:39 EDT
According to https://engineering.redhat.com/rt3/Ticket/Display.html?id=41768
nocpulse-common package was removed from tools channels. Now I see the package
is back. I'll have to talk to rel-eng ...
Comment 12 Jan Hutař 2009-06-02 05:30:14 EDT
Please note this was against WebQA.
Comment 13 Milan Zázrivec 2009-06-02 07:09:01 EDT
Tuesday, June 2nd, nocpulse-common was (again) removed from tools
channels in webqa. Not sure how it got there, but it's gone now.
Comment 14 Garik Khachikyan 2009-06-02 08:20:27 EDT
Created attachment 346242 [details]
satellite520_RHEL53 install log
Comment 15 Garik Khachikyan 2009-06-02 08:21:26 EDT
June 2:
Now another set of dependency errors are in the log.
Please find them attached right before this comment.
----
Error: Missing Dependency: perl(HTTP::Request) is needed by package SatConfig-generator-2.29.5-9.el5.noarch (Satellite/SatConfig-generator-2.29.5-9.el5.noarch.rpm)
Error: Missing Dependency: javamail is needed by package bouncycastle-jdk1.5-1.37-1jpp.1.el5.noarch (Satellite/bouncycastle-jdk1.5-1.37-1jpp.1.el5.noarch.rpm)
Error: Missing Dependency: xerces-j2 is needed by package xom-1.0-2jpp.ep1.3.el5.1.noarch (Satellite/xom-1.0-2jpp.ep1.3.el5.1.noarch.rpm)
Error: Missing Dependency: perl(Date::Manip) is needed by package rhn-moon-5.2.0-16.el5.noarch (Satellite/rhn-moon-5.2.0-16.el5.noarch.rpm)
----
(...so on)
Comment 16 Milan Zázrivec 2009-06-02 08:27:29 EDT
Are you sure architectures of your operating system and the satellite
iso used for installation match?
Comment 17 Garik Khachikyan 2009-06-02 08:36:34 EDT
Actually there are the logs taken from RHTS test script which selects the iso matching to the reserved workflow architecture by a script.

I've just repeated the same test I did previous time.
Yes, it should be right iso selecting.
Comment 18 Milan Zázrivec 2009-06-02 08:45:50 EDT
All the packages that satellite installer complains about (or more
specifically reports missing) are supposed to come from the base
RHEL channel. I'd say the system is either not registered or there's
some other problem with the machine's yum repos setup.
Comment 19 Milan Zázrivec 2009-06-02 08:48:08 EDT
From log file attached in comment #14:
...
This system is not registered with RHN.
RHN support will be disabled.
...
Comment 20 Garik Khachikyan 2009-06-02 09:18:15 EDT
yes, seems something went wrong there, as on a reserved RHTS workflow it's going fine so far (it's on packages installation phase now).

@mzazrivec: thanks a lot for support.

The issue needs to be verified on all supported arch-s still...
Comment 21 Garik Khachikyan 2009-06-03 06:33:56 EDT
# VERIFIED
# ********
version: Satellite-5.2-RHEL-5.3
arch: s390x; i386; x86_64
iso(s): http://barn.rhndev.redhat.com/satellite-isos/satellite-5.2/Satellite-5.2-RHEL-5/<etc...>
# ********

Installation of RHN Satellite processed ok on an inputs provided above.

Note You need to log in before you can comment on or make changes to this bug.