Bug 500565 - RMagick built with ImageMagick 6.4.9 but ImageMagick 6.5.1-2 is installed
RMagick built with ImageMagick 6.4.9 but ImageMagick 6.5.1-2 is installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ruby-RMagick (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 06:19 EDT by Mike Wohlgemuth
Modified: 2009-05-14 00:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.9.1-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 00:10:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Wohlgemuth 2009-05-13 06:19:20 EDT
Description of problem:

I am attempting to install redmine on a rawhide box, and am getting the following error:

rake aborted!
This installation of RMagick was configured with ImageMagick 6.4.9 but ImageMagick 6.5.1-2 is in use.

I have the following RPMs installed:

ImageMagick-6.5.1.2-1.fc11.i586
ruby-RMagick-2.9.1-2.fc11.1.i586

Rebuilding the ruby-RMagick-2.9.1-2.fc11.1.i586 RPM from source against the currently installed packages resolves the error.

Version-Release number of selected component (if applicable):

ruby-RMagick-2.9.1-2.fc11.1.i586


How reproducible:

always

Steps to Reproduce:
1. Follow the instructions at http://www.redmine.org/wiki/redmine/RedmineInstall
   to install from trunk
2. Error happens with the following command line:
   rake db:migrate RAILS_ENV="production"
3.
Comment 1 Mamoru TASAKA 2009-05-13 15:01:15 EDT
Well,

$ ruby -e 'require "RMagick"'
/usr/lib/ruby/site_ruby/1.8/i386-linux/RMagick2.so: This installation of RMagick was configured with ImageMagick 6.4.9 but ImageMagick 6.5.1-2 is in use. (RuntimeError)
        from /usr/lib/ruby/site_ruby/1.8/RMagick.rb:11
        from -e:1:in `require'
        from -e:1
Comment 2 Mamoru TASAKA 2009-05-14 00:10:22 EDT
Will be fixed in next rawhide push. Thank you for
reporting this.
https://fedorahosted.org/rel-eng/ticket/1807

Note You need to log in before you can comment on or make changes to this bug.