Bug 500617 - wrong exclude pattern
wrong exclude pattern
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: mock (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 09:26 EDT by Levente Farkas
Modified: 2013-01-10 00:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-15 11:26:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2009-05-13 09:26:04 EDT
as i wrote in #500611 mock use wrong exclude pattern in 
/etc/mock/epel-5-x86_64.cfg
currently:
exclude=[0-9A-Za-fh-z]*.i?86 g[0-9A-Za-km-z]*.i?86 gl[0-9A-Za-hj-z]*.i?86 gli[0-9A-Zac-z]*.i?86 glib[0-9A-Za-bd-z]*.i?86
which is not working as we assume so change it to at least:
exclude=[1-9A-Za-fh-z]*.i?86 g[0-9A-Za-km-z]*.i?86 gl[0-9A-Za-hj-z]*.i?86 gli[0-9A-Zac-z]*.i?86 glib[0-9A-Za-bd-z]*.i?86
fix the problem.
Comment 1 Clark Williams 2009-05-13 11:11:06 EDT
What package do you catch changing that zero to a one?
Comment 2 Levente Farkas 2009-05-13 11:33:39 EDT
xen-3.0.3 from updates.
anyway if you read bug #500611 's comment you see yum have to work in this way so it's a bug in mock's config.
Comment 3 Levente Farkas 2009-06-16 12:51:16 EDT
ping?
Comment 4 Clark Williams 2009-06-16 13:34:43 EDT
We haven't forgotten you, just been working on work work (as opposed to mock work). I'll be doing a round of mock fixes in a few days.

Clark
Comment 5 Clark Williams 2009-07-08 21:18:06 EDT
Excludes modified in 0.9.17
Comment 6 Levente Farkas 2009-07-09 12:21:55 EDT
do you plan to issue an epel build too? since i see there are only fedora builds:
http://koji.fedoraproject.org/koji/packageinfo?packageID=2544
Comment 7 Levente Farkas 2009-07-09 12:25:29 EDT
and as a side not imho this bug is also applies to _all_ fedora version too not just epel-5. what's more i also think it's not the best solution although it's still better the the current exclude pattern.
Comment 8 Clark Williams 2009-07-09 13:07:39 EDT
Not ready to do a EPEL release yet, still trying to figure out how to deal with RPM validation differences.
Comment 9 Levente Farkas 2009-08-13 06:02:32 EDT
any progress?
Comment 10 Levente Farkas 2009-09-08 10:06:00 EDT
waiting for epel version.
Comment 11 Levente Farkas 2010-01-15 11:26:05 EST
seems to working properly.

Note You need to log in before you can comment on or make changes to this bug.