Bug 500688 - Inconsistent help option in the installer
Inconsistent help option in the installer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Devan Goodwin
John Matthews
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-05-13 13:26 EDT by Pradeep Kilambi
Modified: 2009-09-10 16:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2009-05-13 13:26:39 EDT
Description of problem:

So when I do ./install.pl --help I see the following:

    --run-updater
            Do not ask and install needed packages from RHN, provided the
            system is registered.

    --run-updater=no
            Stop when there are needed packages missing, do not ask.


I dont see the point of same option listed twice for different purposes.

All we need is a --skip-updater if you choose not to and let the updater run by default.
Comment 1 Brandon Perkins 2009-05-14 10:57:51 EDT
Minor, but should be easy fix.
Comment 2 Devan Goodwin 2009-05-26 09:26:42 EDT
Looks like this was designed to support three states:

1. 'run-updater' not defined, default to prompting the user to proceed with package installations.
2. 'run-updater' set to yes, automatically start installing missing deps.
3. 'run-updater' set to no, print what needs to be manually installed and terminate the installer.

It looks like the author specifically was trying to prevent trying to install packages the administrator didn't expect.

We sure we wish to proceed with two states, default to automatically installing and terminate if --skip-updater was defined (and deps are missing)?
Comment 3 Devan Goodwin 2009-05-26 09:35:57 EDT
My preference would be to go to the two states, automatically assume we can attempt to auto-install required dependencies if the system is registered, and print what's missing and terminate if --skip-updater is defined.

If we choose not to go that route we can clarify the help a little better, something like: 

--run-updater=<yes|no>
Set to 'yes' to automatically install needed packages from RHN, provided the  system is registered. Set to 'no' to terminate the installer if any needed packages are missing. Omit this option to be prompted during installation.
Comment 4 Jan Pazdziora 2009-05-26 09:41:44 EDT
The only problem I can see, what is going to happen if you run the installer with both --run-updater and --skip-updater?
Comment 5 Devan Goodwin 2009-05-26 09:52:23 EDT
Spoke to Jan and he feels the current three state behaviour is desirable and important, as well as consistent with other options. (if undefined, prompt)

As such I will keep the options as they are today and just clarify the help information a little bit as per previous comment.

If this logic is actually causing problems and needs to be restructured we can consider as another issue in the future.
Comment 6 Devan Goodwin 2009-05-26 11:20:40 EDT
Fixed in spacewalk.git: 9b636a23f0f9510fb678d02ceb00c25238fec76b
Ported to satellite.git: 5eb98be
Comment 7 John Matthews 2009-06-11 09:20:45 EDT
Verified, ISO: Satellite-5.3.0-RHEL5-re20090605.1-i386-embedded-oracle.iso

As per comment #5, verifying help info has been updated.
--run-updater=<yes|no>
            Set to 'yes' to automatically install needed packages from RHN,
            provided the system is registered. Set to 'no' to terminate the
            installer if any needed packages are missing.
Comment 8 Michael Mráka 2009-08-27 10:21:44 EDT
Verified in stage -> RELEASE_PENDING.

    --run-updater=<yes|no>
            Set to 'yes' to automatically install needed packages from RHN,
            provided the system is registered. Set to 'no' to terminate the
            installer if any needed packages are missing.
Comment 9 Brandon Perkins 2009-09-10 16:36:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.